Mautic Community Forums

API error with Mautic automateplus

a while ago i created the api credentials with auth2 type, and it worked fine with the automate plus wordpress plugin ( https://wordpress.org/plugins/automate-mautic/ ) that helps in importing registered users automatically from my wordpress site to my mautic self-hosted installation… after some months when i tried the same thing with another wordpress site it gives me an error, and when i disabled it for the first site where it worked fine and tried to re-enable it again, it also failed to integrate this time. Below is the error that is being returned in my browser:

{“errors”:[{“message”:“The redirect URI provided does not match registered URI(s).”,“code”:400,“type”:“redirect_uri_mismatch”}],“error”:“redirect_uri_mismatch”,“error_description”:“The redirect URI provided does not match registered URI(s). (error and error_description are deprecated as of 2.6.0 and will be removed in 3.0. Use the errors array instead.)”}

and the error i’m getting in the mautic error-log file from my cpanel (/mauti/app/logs/mautic_prod-2018-01-19.php) is below:

mautic.NOTICE: Swift_TransportException: Expected response code 220 but got code “”, with message “” (uncaught exception) at /mautic/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php line 383 while running console command mautic:emails:send [] []

anyone to assist?

Have you upgrade your WordPress recently ?

What WordPress version you have? It seems your WordPress version issue.

why don’t you create and API credentials again and of-course delete the plugin from back-end and again install then integrate with your mautic API, it should work…

If not that read automate-plus WordPress plugin documentation , might be WordPress version issue.