Mautic Community Forums

Bounce email not getting monitored - despite "Success" on Test

I have set up my monitored inbox, my bounce email and am using Amazon SES. Everything checked out when testing and says “Success!”, but when I run the cron job to mautic:email:fetch I get an error:

Error communicating with the IMAP server: IMAP Authentication cancelled

I am using Amazon SES to send my emails. I used the hostgator IMAP settings that work for all other emails on my server. This seems to be the hiccup as the bounce@mydomain.com emails are arriving, but Mautic is not actually monitoring them.

I originally thought this was properly set up, but it seems I have had unmonitored bounces for several months now and this is affecting my deliverability (going to spam).

I see that there is an option using a webhook to do this with Amazon SES and have set up the confirmation per the instruction in the mautic documentation (which are not really clear) . There is no indication if I should do anything in the Mautic instance (add a webhook?) or just follow the instructions for setting up the amazon instructions. Even if this does work - I still have 15k bounces/issues that need to be monitored from the inbox to update my contacts.

Any help is much appreciated!!

Monitored Inbox settings

ANY HELP Appreciated!!!

UPDATE: Just spoke with hostgator and all of my login info is correct, and they can see where the email access request is getting through to the cpanel - but that is just freaks out over the certificate not “exact matching” as on shared servers they do the wildcard thing. Apparently most email services understand how to work around this, but the one for Mautic does not.

So running a cron or command of /opt/php56/bin/php /home4/user/public_html/domain.com/m/app/console mautic:email:fetch

results in an error of:

Error communicating with the IMAP server: Certificate failure for mail.mydomain.com: Server name does not match certificate: /OU=Domain Control Validated/OU=Hosted by HostGator.com, LLC./OU=PositiveSSL Wildcard/CN=*.hostgator.com

I have tried this with PHP version 5.6 and 7.0. I have tried this with Mautic versions 2.5.1 and 2.12.1 and also I have tinkered with other settings such as IMAP host mail.mydomain.com vs gator4041.hostgator.com:#### in varied combinations of encrytions (None, SSL, SSL without cert, TLS, TLS without cert) and here are the other errors I get, seemingly along the same lines and issue:

Error communicating with the IMAP server: Connection failed to mail.mydomain.com,993: Connection timed out

Error communicating with the IMAP server: IMAP Authentication cancelled

Error communicating with the IMAP server: TLS/SSL failure for mail.mydomain.com: SSL negotiation failed

I got your problem

@alainarae
First question why are you using your default email server the one that comes with HostGator? (Why you don’t use an external Email Services Provider like Amazon SES, Sendgrid etc.

The second question you know you are LIMITED using your default email services provider and your email will have more change to be flag as spam and will lower the email delivery rates right.

Hi @Joan Nin,

I am using Amazon AWS for the SMTP and that is doing great. Amazon suggested for IMAP I just use my hostgator setup. The emails are filling up in this inbox, but mautic does not seem to be monitoring the inbox, despite the “success!” with checking the setup. Something about Mautic needing “exact credentials” for SSL and not meshing well with the wildcard authentication of hostgator’s shared server.

Is your inbox monitoring working? If so - what do your use for your IMAP server?

Thx-
alaina

IMAP extention must be enabled on your server

@bizcrony I called and asked and hostgator says it is enabled, and that they can see the request come in, just that it gets stuck at the certificate (it does not exact-match as they use a wildcard validation on shared hosts). Did you get yours working?

Yes its working for me and for my clients as well. Why don’t you upgrade your mautic and try.