Broadcast messages to segment are never sent

My Mautic version is: 4.0.2 using official docker container
My PHP version is: 7.4.25
My Database type and version is: mysql 5.7.34-37

My problem is: My broadcast messages are always queued and never being sent. Steps to reproduce:

  1. I add two contacts and add them to the “Test” segment manually.
  2. I define some test email and set the “Test” segment.
  3. I want to send the email to the segment so I click “Send” and confirm.
  4. Now in the “Stats” column by the emails I see “2 Queued” “0 Send” and that is not changing even after few hours.
  5. I check the /var/www/html/var/spool directory in running docker container - it is empty.

Campaign emails are sent without problems, only broadcast are not. It is crucial for me, what should I do diagnose it?

These errors are showing in the log:

Steps I have tried to fix the problem:
I run mautic:broadcasts:send and swiftmailer:spool:send and nothing changes.

are your cronjob setup properly ?

can you paste them here so we can see.

Do you have queueing setup in your emails settings or set to send immediately

Mike, I think this is the other queueing issue.

@kopeuegv , plz check if in settings / config / email settings by Default Frequency Rule the value is NOT 0 / day.

1 Like

correct, the hint is Queued :slight_smile:

I did not read the first message thoroughly.

To add to Joeys reply, as he has told me a few times, if it is set to 0/day change it to 100.

If you go to the contact that is queued and look in the events section of the contact card you will see the mail has not been sent with a warning, if you toggle this open you will see that it is most likely scheduled for the same time the next day

That was Default Frequency Rule = 0, thank you guys!

1 Like