Can you disable click tracking of privacy policy links in emails?

My Mautic version is:4.2.1

We send out a number of emails and they all contain links to our privacy policy. Is there a way to stop Mautic from tracking clicks in emails to these (privacy policy) links so they don’t show up in the reporting and only track clicks on the call to action?

Hi, here is an underrated, underdocumented feature in Mautic.

You can disable certain links by adding the mautic:disable-tracking="true" attribute to the link in the html code.

Your link before:
<a href="">Privacy Policy</a>

Link not to be tracked:
<a href="" mautic:disable-tracking="true">Privacy Policy</a>

Good luck to you :slight_smile:


Thank you!
That will make life so much easier

My Mautic version: 4.4.1
PHP Version 7.4.29

I suppose you are adding the additional mautic:disable-tracking="true" code in “code-mode-template” of the email:

Is there the possibility to add this option using the GrapesJS-Editor or the Classic-Editor?

I tried:

  1. using the GrapesJS-interface: there is no option to add this additional code:

  2. using the Edit-code button, I inserted the option inside the mj-element like this:

    But it seems the tracking is not disabled for the links. I sent the email to a test-segment. The email statistics includes also those links:

  3. I do not see another method by still using the GrapesJS-Editor. Would the Classic-Editor have this option?

To “downgrade” all the emails to using code-mode would be … annoying.

You inserted the attribute to the image, not the link.

Yes, but there is no <a> tag in the mjml-code.
I take your answer as: with GrapesJS-Editor cannot work.
Therefore I will try to change to Classic-Editor.

You can still use the anchor in text links.
Maybe it would make sense to play around with


Something new learned: how is the block <mj-raw> to be used. Thank you Joey !

Unfortunately, the tracking is still there.

  1. I added the attribute on the first image appearing by default when inserting the mj-raw block:

  2. I checked that the attribute was saved - passed.

  3. The email is a segment email. The segment is a test segment, where I manually add email-address.

  4. Sent the email to the added contact in segment.

  5. Checked in outlook the email link:

So the attribute does not work either with the mj-raw .

I am checking with the classic-editor.

I’m sorry that didn’t work. I don’t have better idea now.

Confirmation: :white_check_mark: it works with classic-editor.
I suspect that the link with the attribute must not exist anymore inside the email without the attribute, otherwise I suppose it will not work - it would have also no purpose then.

I wanted long ago to revert to classic-editor, as I find GrapesJS-Editor so buggy. This is the moment!