Link without tracking in a Dynamic Content on Landing Page

Your software
My Mautic version is: 4.4.8
My PHP version is: 7.4.29
My Database type and version is: 10.3.38-MariaDB-0ubuntu0.20.04.1

Your problem
My problem is:
I created a Dynamic Content for a Landing Page.
Inside is a Link.
I added the Dynamic Content on a Landing Page using Code Mode template.
The Link inside Dynamic Content is hashed by Mautic, for tracking purposes.
I do not need the tracking, so I tried using


for the link inside Dynamic Content, but the attribute is every time removed when I exit the CodeView.

Steps I have tried to fix the problem:

Is there a possibility to skip the hashing of the link that are in a Dynamic Content?

I am the one who wrote the PR above, we can extend it to dynamic content, I don’t have time at the moment write new code but if want start a PR and I will help you

Wow, I would love to have you by my side !
But, you should take me from zero. I even do not know what do you mean by “start a PR”.
I know VBA, some API, some C++.
JavaScript, php and such programming languages … I am a beginner, an amateur.
Is there a tutorial/video to understand how to start a PR ?

Is there a tutorial/video to understand how to start a PR ?

@IonutOjicaDe Documentation on how to contribute to Mautic is available here:

I’m sure there are many videos on Youtube on how to start a PR.

I haven’t contributed to Mautic (just evaluating the tool), but one way of doing this would be:

  1. Pull the Mautic repo on your laptop
  2. Make changes to the code (changes can be very minor)
  3. “Commit” and “push” those changes via a branch to the repository
  4. Navigate to the repo and open a PR using the branch you committed
1 Like

@jonathan.marsan I must digest your email. Step 2 (make changes to the code) is still an alien world to me.

I suppose I found why the attribute is eliminated. To edit the DynamicContent is not Froala being used but CKEditor!

When editing the content (the cursor is inside) there pops up another Menu, from the CKEditor.

Menu from Froala, while the cursor is not inside:

Menu from CKEditor4, while the cursor is inside editor:

Can someone guide me, where is the list htmlAllowedAttrs for the CKEditor ?

For the Froala, I know now, thanks to @jonathan.marsan github fix (Fix `mautic:disable-tracking ` by mabumusa1 · Pull Request #10355 · mautic/mautic · GitHub)

Thanks @IonutOjicaDe, it seems that @jonathan.marsan has kicked off the process of a PR. You can find in Mautic Slack channel, I will help you get your Pull Request (PR) merged and get this bug fixed.

@jonathan.marsan I am amazed that you jumped to help on this topic although you are still evaluating Mautic, is there anything I can do to get you started and contribute to Mautic?

@IonutOjicaDe for the issue itself, I think you are around the right area, we need to make sure the editor used is actually saving the attribute before it is sent back to the PHP code and saved in the database.

@m.abumusa thank you also for your support! I am very glad to be part of this community.

I suppose the issue is bigger: I have the GrapesJS plugin disabled, to only use the Froala Editor.
And here (in Dynamic Content) I see the CKEditor, which belongs actually to the GrapesJS plugin, which is disabled.
How can that be?

Is CKEditor implemented in Mautic directly? And is being used also without the GrapesJS plugin?
I thought, by disabling the GrapesJS plugin, I will only use the Froala Editor all over the places where an Editor is needed…

Later edit: the PR is there: Mautic removes mautic:disable-tracking attribute for links in dwc by IonutOjicaDE · Pull Request #12378 · mautic/mautic · GitHub