Cannot change language

Your software
My Mautic version is: 5.0.3
My PHP version is: 8.1.27
My Database type and version is: mariadb Ver 15.1 Distrib 10.6.16-MariaDB, for debian-linux-gnu (x86_64) using EditLine wrapper

Your problem
Having issues changing language, I send emails in Swedish and English and I’d like the unsubscribe string in the Swedish emails to be in Swedish. So I tried to change the system language to Swedish to load the translation but it didn’t work. Got this error message: “Your request could not be processed, please try again.”

These errors are showing in the log:
No error in apache2 error log.

Steps I have tried to fix the problem:

I checked the browser console:
POST 500 (Internal Server Error)

There’s an error 500 and I cannot see in the the Apache error log. Gonna have a peak at php.ini to see if it logs errors at all… this is a brand new VPS.

Nothing in Mautic’s logs either. Where do I begin to debug this?

You need to define where this 500 error is happening.

Is it browser side or server side?

If it’s server side;
Depending on your configuration, check the main web server log (errors and access) located in your /var/log directory.

Errors may be reported there when it does happen before a vhost exec.

** Most of the 500 errors reported here that I looked at were about bad permission/ownership. This doesn’t come without a surprise. Documentation is leading lambda users in that direction for an unknown reason.

i.e. The upgrade documentation is a 100% 5xx error outcome. Running console as root. Ridiculous idea (and the results are there to explain why you shouldn’t).

A 500 error is an HTTP error, so that means server-side. I’ve checked all the logs (php, sys and apache2). I’ll try running recursive chown/chmod again to ensure all directories have correct ownership and permissions. Mautic reports correct folder permissions when I check.

Check the logs… It’s sure there.