Mautic Community Forums

COntact not being entered into segment on Campign forms (but working on standalone form)

I have an issue with leads not being entered into the segment that they are supposed to go into from a campaign form. I am still trying to understand how everything works. I have found this on the Mautic forum, and wonder if it still applies (but with segments now in place of lists):

“Standalone form - Open the Actions tab in the form configuration and add the “Modify lead’s list” action.



Campaign form - Add the “Modify lead’s list” action after “Submits a form” decision in the Campaign Builder of the campaign where you use this form.”

According to Contact Source widget in the campaign builder, “Contacts that are members of the selected segments will be automatically added to this campaign.” They are not being added. I have tried to add a step to Modify Content Segment after the Contact Source, but the contacts are still not being added to the contact segment.



I have found that when using a standalone form, the leads are being entered into the segment correctly. 1. Why would the standalone form be working placing the leads into the segment correctly, whereas the campaign form is not? 2. Is there any harm in using a standalone form as the start point for an entire funnel?

I have an issue with leads not being entered into the segment that they are supposed to go into from a campaign form. I am still trying to understand how everything works. I have found this on the Mautic forum, and wonder if it still applies (but with segments now in place of lists):
"Standalone form - Open the Actions tab in the form configuration and add the “Modify lead’s list” action.

Campaign form - Add the “Modify lead’s list” action after “Submits a form” decision in the Campaign Builder of the campaign where you use this form."
According to Contact Source widget in the campaign builder, “Contacts that are members of the selected segments will be automatically added to this campaign.” They are not being added. I have tried to add a step to Modify Content Segment after the Contact Source, but the contacts are still not being added to the contact segment.

I have found that when using a standalone form, the leads are being entered into the segment correctly. 1. Why would the standalone form be working placing the leads into the segment correctly, whereas the campaign form is not? 2. Is there any harm in using a standalone form as the start point for an entire funnel?