Mautic Community Forums

CSRF token error. Try to refresh the page and try again

Your software
My Mautic version is: 2.16x + 3.x
My PHP version is: 7.2 & 7.3
My Database type and version is: MariaDB

Your problem
My problem is:

I have very similar installations of mautic for a number of instances and on some of them I continually get the token refresh error.

There has to be an easy fix to this that I am not aware of.

I am running NginX server on Ubuntu 18.04 & 20

So looking for someone to point me in the direction I cannot see.

These errors are showing in the log:

Steps I have tried to fix the problem:

Hi Mikew,

I’ve seen these after the session has timed out. In my browser I get this until I refresh the page and then login.

Have you tried clearing your browser’s Cache? Or moving to another Browser?

Anything showing up in the logs?

Logs don’t show anything. I have used it in different browsers, not sure if it is a web server setting or something inside Mautic. But certain instances I can be in forever and certain after a minute I get this, sometimes even 3 times in a row.

Hi fellow Mautic Guru’s - does anyone know how to fix this issue - is it a Mautic thing or a server thing ?

@joeyk ? @ekke ?

Would really appreciate some assistance here

1 Like

It seems to have disappeared with the latest version :wink:

Man I missed this sorry. Not like I know the answer…

1 Like