Custom Header is not showing in the email

Your software
My Mautic version is: 2.15.3
My PHP version is: 7.1.32

Your problem
My problem is:
When I sent an email with a custom header that was set in the advanced tab, I wasn’t able to find the custom header from the email.

Here are the steps.

  1. Create an email template with choosing a segment list
  2. Set a custom header key & value pair in the advanced tab
  3. Save the template and click send
  4. Check Email (I checked it from gmail) and its header
  5. No custom header found in the email header

For your information, I used sendgrid and I also tried to do the same steps via api (creating a email with segment & custom header and send email). However, it was still the same issue.

Any help would be greatly appreciated.

Thank you.


These errors are showing in the log: No error log found

Steps I have tried to fix the problem: I just keep searching a google/Muatic forums to see if there is any solution.

1 Like

I am getting the same problem. I need to use the sandbox from sendgrid, to testing the performance on mautic.

I came across the same problem today.
Did anybody solve this or use this feature?

I use Amazon SES for sending. But I didn’t find something on their side to turn on or suppress custom headers in E-Mails.

Same problem here, mautic version 3.3.3 I am trying to include List-Unsubscribe header, but the header seems to be ignored.