Don't see referral bundle mautic 4.3.1

I have a fresh mautic 4.3.1 install, which is working nicely. However, I tried to install the referral bundle (maatoo/mautic-referrals-bundle - Packagist), but it doesn’t show in the manage plugins page.

Tried to install via composer (didnt’t work), next I installed it via unzipping the bundle in the plugins directory. This always worked before, but now it doesn’t show.

What am I doing wrong now :wink:

Thanks in advance


It’s possible, that this plugin is abandoned.

Coud be. Was working fine on 4.2.1. Shame really.
Do you know of any plugin that would achieve the same result (creating a form that allows the filled in names or emails would to be associated with the person filling it in)?

I wouldn’t call it a shame, I think its the “open source - free stuff effect”.
This is why I rather pay for my plugins, and I know what to expect.

I don’t know any similar plugin.
But I think you can pay someone to update it. I don’t think its a huge update. Try upwork.
It can be just a config issue.

I think these folks made the plugin, write to them:

I’d gladly pay for a plugin like this, as long as it works. Still a shame that it isn’t working ;).

I don’t see a reason why it wouldn’t work (it all looks okay, and is similar to previous installs).
However, this is a composer install and tried to add the plugin via unzipping (could that be it?).

If I install the plugin via composer I get this error:

- mautic/composer-plugin[1.0.0, ..., 1.0.1] require composer-plugin-api ^1.0 -> found composer-plugin-api[2.3.0] but it does not match the constraint.
- maatoo/mautic-referrals-bundle[1.0.0, ..., 1.0.3] require mautic/composer-plugin ^1.0 -> satisfiable by mautic/composer-plugin[1.0.0, 1.0.1].
- Root composer.json requires maatoo/mautic-referrals-bundle 1.* -> satisfiable by maatoo/mautic-referrals-bundle[1.0.0, 1.0.1, 1.0.2, 1.0.3].

So that is why I switched to a manual install.
Anyone have a similar problem?

Kind regards,

The sollution turned out to be this:

1 Like