Dynamic Focus Item Not Firing

This is probably user error/lack of understanding, but to me, something isn’t working as I think it’s supposed to…

This is set up on a Wordpress site using the Mautic Plugin.

I want to display a focus item based on a few criteria. For testing, I have a very basic campaign set up.

The campaign is: Segment > Device Visit > Action: Display Focus Item.

I can see in the contact details that the Campaign portion of it is being processed, however the focus item does not load on the page.

I even set up a different site using a different theme, with the same issue.

If you look at the contact logs, you can see that campaign info… It’s just that the focus item does not load on the page.

If I go to that site and manually add the focus item’s javascript on a page, the focus item loads just fine. It simply won’t load via the campaign.

The test Focus Item is set to load for every page.

Hi! Did you solve this issue?

Hi, your focus item probably fired, but you don’t see it cause the person already left the campaign.
This is my workaround:

Good luck to you!


Hi, thank you for the suggestion! I tried to do as you said but still not working :frowning: As you were saying, the focus item fires, as I can see from the contacts involved in the campaign, but in reality it doesn’t appear.

very good explanation here. Jump to event only jumps to Mautic’s action, not user’s decision so this solves the issue
this campaign method uses segment. Segment has more options than filter - which is used in DWC (holding focus item inside it)'s JS code embedded on landing page - method