Mautic Community Forums

Editing campaign in two browser tabs locks the campaign so it's not editable at all in 3.1

Your software
My Mautic version is:3.1
My PHP version is: 7.3

Your problem
My problem is: In Mautic 2.x, I was able to duplicate the Mautic browser tab so that I could reference fields in one tab while I was making changes to the campaign in another. If I accidentally edited the campaign in both tabs, the last save would update the campaign regardless of what was happening in the other tab.

Now, in 3.1, I tried the same trick and I was editing/updating a campaign and it looks like it create a record lock on the campaign so that it’s no longer available at all.

I also cloned the campaign with the hopes the I could just abandon the locked campaign and the clone inherited the same issue.

This campaign is very long and complex so I’m hoping there is a way to remove the the lock in the database, and if, not, at least I’ve documented the behavior. :slight_smile:

These errors are showing in the log:

Steps I have tried to fix the problem:

Update. I’ve discovered that I can edit the campaign from the edit check box to the left of the campaign description in the campaign list. The issue identified above was from clicking on the hyperlink name of the campaign.

After successfully opening the campaign builder
I can edit and successfully save using Apply.
Then close builder

Save and Close on the campaign overview returns the same error as above.