Mautic Community Forums

Emails in campaign not sending

Hi,

I have created a campaign with five emails in Mautic and tried sending it to my own email address yesterday. I added it manually to the segment specified in the campaign to trigger the first email immediately.

After a couple of hours I got the email that was supposed to be in fourth place, none of the others actually came in even though it says in in the contact history that they were all send correctly.

Did anyone else have the same struggle? I would appreciate any help.

What shows in your log files?

Post a screenshot of campaign.

The error log is empty, it says: “Today’s Mautic error log is empty. Check server error log for error messages Mautic didn’t have a chance to catch.”

Here’s the screenshot of the campaign and what it shows for the contact

Hi, couple of questions:
Are you sure you don’t have the messaging frequency set for contacts? (In the email settings)
When you are in the From and To field, Gmail sometimes marks it as dangerous. Could you plz check if they didn’t land in spam or got holden up sometow?
Also: when you click on the email icon itself, it should toggle more info. Maybe you can see something there, what happened.
Good luck,
J

2 Likes

So, I checked the messaging frequency. It was set on 0/day, I deleted it and tried to send out the campaign again. This time I immediately received the first email, so that worked. Now, the second email is supposed to be sent already but did not get triggered.

The error log shows this now:
[2020-11-12 08:26:11] mautic.NOTICE: PHP Notice - Undefined index: path - in file /opt/bitnami/apps/mautic/htdocs/app/bundles/CoreBundle/Controller/ExceptionController.php - at line 120 {“request”:"[object] (Symfony\Component\HttpFoundation\Request: GET //console HTTP/1.1\r\nAccept-Encoding: gzip\r\nConnection: close\r\nHost: mautic.marblear.com\r\nReferer: https://52.207.144.195/console/\r\nUser-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36\r\nX-Php-Ob-Level: 1\r\n\r\n)",“exception”:"[object] (Symfony\Component\Debug\Exception\FlattenException: {})",“logger”:null,“class”:“Symfony\Component\HttpKernel\Exception\NotFoundHttpException”,“currentContent”:"",“layout”:“Error”,“code”:404,“anonymous”:true,“baseTemplate”:“MauticCoreBundle:Default:slim.html.php”,“templatePage”:false,“template”:“MauticCoreBundle:Error:404.html.php”,“templating”:"[object] (Symfony\Bundle\FrameworkBundle\Templating\DelegatingEngine: {})",“statusText”:“Not Found”,“url”:"//console",“urlParts”:{“host”:“console”}}
[2020-11-12 14:01:05] mautic.WARNING: Received SES webhook of type ‘Notification’ but couldn’t understand payload

Does anyone have an idea what that means?

Hi,
What SMTP are you using? Own or third party?
This error seems like a SES webhook error to me?
Also: all cronjobs properly set?
Do you have console:campaigns:rebuild (or update)
console:campaigns:trigger
Also: are you using email queue?
Thx

Hi,
I’m pretty new to all this and didn’t set the account up myself so I don’t know about the SMTP. The cronjobs seem to be all set up properly. In the end I received all emails, so that problem should be solved. The only problem left there was the timing. Indeed I queued the emails in different intervals but instead of sending them out in that way, mautic triggered the mails hourly for some reason…

Thank you already for your help!