Error 500: broken path to log an cache directory

Your software
My Mautic version is: 3.1.2
My PHP version is: 7.4
My Database type and version is: Mysql

Your problem
My problem is: So I tried changing the path to the logs and cache directory manually because it had the path of an older version of mautic. Doing so, I put the wrong path and now can’t access my dashboard. Is there a quick fix to it? Thanks!

These errors are showing in the log:

Steps I have tried to fix the problem:

Look in your mautic/app/config/local.php file

<?php $parameters = array( 'db_driver' => 'pdo_mysql', 'db_host' => 'localhost', 'db_table_prefix' => 'ar5d_', 'db_port' => '3306', 'db_name' => 'redacted', 'db_user' => 'redacted', 'db_password' => 'redacted', 'db_backup_tables' => 0, 'db_backup_prefix' => 'bak_', 'db_server_version' => '5.5.5-10.4.14-MariaDB', 'mailer_from_name' => 'Site Owner', 'mailer_from_email' => '', 'mailer_transport' => 'sendmail', 'mailer_host' => null, 'mailer_port' => null, 'mailer_user' => null, 'mailer_password' => null, 'mailer_api_key' => null, 'mailer_encryption' => null, 'mailer_auth_mode' => null, 'mailer_spool_type' => 'memory', 'mailer_spool_path' => '%kernel.root_dir%/var/spool', 'secret_key' => 'redacted', 'site_url' => 'redacted', ); This is what I have in the file. What exactly do I change?

@shaysashcov I have redacted the sensitive information in your post - please don’t share credentials in the forum, just replace the sensitive stuff with ‘redacted’ or something similar :slight_smile:

Thank you, sir.

You’re welcome, and actually I’m female so no need for the Sir :slight_smile:

My apologies ma’am.
Is there a solution to my problem? :grimacing:

Line 27 and 28 in my local.php has cache and logs directory. Your directories won’t be exactly the same because my dev environment is probably different from yours. Centos 8 with Plesk Panel.

||'cache_path' => '/var/www/vhosts/',|
||'log_path' => '/var/www/vhosts/',|

Have you cleared cache after you changed the paths? If not I would do so.