Mautic Community Forums

Error connecting to the aws ses with sns

hi

I am connecting through programmatic access API.
NS provider Cloudflare

endpoint i specified during the creation of SNS topic and subscription is : https://mautic.domain.com:2087/mailer/amazon_api/callback
but AWS SNS subscription is showing pending.

how to fix it.

thx
sayantan

Interesting. That should work out of the box. Do you have Amazon ses api enabled right? Not SMTP.

yes . ofcourse it is api with i am user who would have full access to sns and ses. sns and ses are not within sandbox though.

I had this issue. I tried changing regions then it magically started working.

so aws ses , sns, and mautic must be within the same region? or just I can use SNS for the same region?
my instance has full access for them within a custom role assigned to that instance why can not we have cross-region?

but i tried the same with fluentcrm it worked there. i think it is a glitch.

I don’t think region has anything to do with it. I have a general listener, that captures data from any region.
What @robm is saying: he switched the region (probably back and forth) and suddenly started to work.
J

exactly, like a blind monkey smashing keys until something works. In this case, the region change made all the difference, no idea why. It shouldn’t but it did.

@robm @joeyk can we have a VPC to VPC inter-regional peering within same account to resolve it?
for example, if VPC @ Ohio and VPC@Sydny wouldn’t share the same CIDR then we can have a peering between them. but can it be resolved that way?

Sorry I don’t know what a VPC is

hi

please take look at this if you want to know about vpc peering :globe_with_meridians:

ref : What is VPC peering? - Amazon Virtual Private Cloud

As far as I know, SES and SNS must be in the same AWS region to work.

1 Like

@wlandgraf SES detected the SNS topic perfectly which means they are in the same region already but the ec2 lies with the different region where actually mautic is deployed. if i need to change the region of ec2 for such purpose it means if some client using a self hosted node and want to use aws ses /sns as an integrated service their instance will fail to connect too ,(of-course in logical sense)

1 Like