Error installing mautic in step 2, site offline

Your software Apache2.4, system centos7 , server VPS Contabo.
My PHP version is :7.4
My MySQL/MariaDB version is (delete as applicable): MySQL 8

Updating/Installing Errors
I am (delete as applicable): Installing / Updating
Upgrading/installing via (delete as applicable) : Web / Command Line

It was not via ssh but manually unzipped in the AApanel panel directory

These errors are showing in the installer :
Error installing mautic in step 2, site offline

These errors are showing in the Mautic log :

error logs: [Thu Sep 08 17:53:03.500361 2022] [proxy_fcgi:error] [pid 11346:tid 139998137562880] [client] AH01071: Got error ‘PHP message: PHP Warning: require(/www /wwwroot/ failed to open stream: There is no such file or directory in /www/wwwroot/ /doctrination/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 197PHP message: PHP Fatal error: require(): Failed opening required ‘/www/wwwroot/ doctrine /orm/Proxies/__CG__MauticUserBundleEntityRole.php’ (include_path=’.:‘) at /www/wwwroot/ on line 197PHP message : PHP warning: Undefined variable: inline at /www/wwwroot/ at line 77’, referrer: Mautic
Your problem
My problem is : Hi! Guys, could anyone help me? I went up the mautic through the directory and unzipped it, it’s the latest version, when loading it gets this offline site image error in installation step2, disable puntv in install_functions =, this can load the installation step 1 error now there is an offline error in step 2.
I’m using apache2.4, php 7.4, VPS contabo, AApenel Panel, msql 8 and phpMyadmin, cloudflare dns without proxy enabled.

Steps I have tried to fix the problem : offline error in step 2

Hi, try installing it, via CLI, gui version can lead to all sorts of problems.


  • delete cache with rm -rf var/cache/dev/* var/cache/prod/*
  • check that php dependencies are installed (check if vendor folder exists & contains sub folders with php files in them)
  • install mautic with the following command
php bin/console mautic:install --db_host=localhost --db_port=3306 --db_name=<db_name> --db_user=<db_user> --db_password=<db_pass> --admin_firstname="<firstname>" --admin_lastname="<lastname>" --admin_email="<admin_email>" --admin_password="<admin_pass>"

(of course change the params to your needs)

[optional] Let us know, how it goes :slight_smile: