Mautic Community Forums

Form field value shows [Object object]

I am a first time Mautic user. A new Contact based on a web form is not being added to the correct segment. I am using the campaign builder with a condition based upon a Form Field Value. I select a custom form field but the values populated in the form show [Object object]. This is particularly unexpected as when using the field in a Contact Field Value the value is correctly populated. I have tried to replace the [Object object] with the correct form value but it didn’t help.



Does anyone have any thoughts? Is the [Object object] likely to be the reason why I can’t add the user to the correct segment?



The only thing shown in the log is:

Code:
[2017-06-27 15:20:27] mautic.WARNING: PHP Warning - Illegal offset type - in file /storage/www/mautic/app/bundles/FormBundle/Form/Type/CampaignEventFormFieldValueType.php - at line 104 [] [] [2017-06-27 15:20:27] mautic.WARNING: PHP Warning - Illegal offset type - in file /storage/www/mautic/app/bundles/FormBundle/Form/Type/CampaignEventFormFieldValueType.php - at line 104 [] [] [2017-06-27 15:20:27] mautic.WARNING: PHP Warning - Illegal offset type - in file /storage/www/mautic/app/bundles/FormBundle/Form/Type/CampaignEventFormFieldValueType.php - at line 104 [] [] [2017-06-27 15:20:27] mautic.WARNING: PHP Warning - Illegal offset type - in file /storage/www/mautic/app/bundles/FormBundle/Form/Type/CampaignEventFormFieldValueType.php - at line 104 [] []

tmp.png
mautic.png

I am a first time Mautic user. A new Contact based on a web form is not being added to the correct segment. I am using the campaign builder with a condition based upon a Form Field Value. I select a custom form field but the values populated in the form show [Object object]. This is particularly unexpected as when using the field in a Contact Field Value the value is correctly populated. I have tried to replace the [Object object] with the correct form value but it didn’t help.

Does anyone have any thoughts? Is the [Object object] likely to be the reason why I can’t add the user to the correct segment?

The only thing shown in the log is:

[2017-06-27 15:20:27] mautic.WARNING: PHP Warning - Illegal offset type - in file /storage/www/mautic/app/bundles/FormBundle/Form/Type/CampaignEventFormFieldValueType.php - at line 104 [] []
[2017-06-27 15:20:27] mautic.WARNING: PHP Warning - Illegal offset type - in file /storage/www/mautic/app/bundles/FormBundle/Form/Type/CampaignEventFormFieldValueType.php - at line 104 [] []
[2017-06-27 15:20:27] mautic.WARNING: PHP Warning - Illegal offset type - in file /storage/www/mautic/app/bundles/FormBundle/Form/Type/CampaignEventFormFieldValueType.php - at line 104 [] []
[2017-06-27 15:20:27] mautic.WARNING: PHP Warning - Illegal offset type - in file /storage/www/mautic/app/bundles/FormBundle/Form/Type/CampaignEventFormFieldValueType.php - at line 104 [] []