Mautic Community Forums

Form not Redirecting to URL after Successful submit (Please Wait)

I embedded the form on my WordPress site and set it up to redirect to a thank you page on the same WordPress site. BUT it doesn’t redirect

On Mautic Preview, it redirects OK
On WP, it just hangs on Please Wait
But the form contact actually goes through to Mautic segment where I set it to go to
HERE is the form (its a click to pop form - the >>>CLICK HERE <<< at the bottom of the page) [https://single-parent.club/reading-head-start-review]
Here is the thank you page where its suppose to redirect [https://single-parent.club/thank-you-reading-head-start/]

On your site im getting a CORS error:

Check that you have your site listed in Mautic’s CORS settings

I have just done that. I have added my site to CORS,
But its still not working. Still stuck on Please wait. ANy further help?

Make sure to add all versions of site (with and without www and https) to CORS setting
If this doesnt work, Open the htaccess file in the root of Mautic installation and add this line:
Header always unset X-Frame-Options

Close the file and restart the webserver

Adding all the variables to CORS didnt work.
Possible to guide me where exactly to add the text?
There are 126 lines and I am not sure where exactly to place it

I noticed, you have Wordress installed on this server / domain.
Do you have Wordfence plugin installed by chance or any other “protective” measure?
That could mess with your Mautic.
Joey

I dont have any such plugins. Here is a list of plugins that comes close to what you think:
Akismet Anti-Spam
Disable Comments
W3 Total Cache

I have seen many people with same error solved it by adding Header always unset X-Frame-Options to htaccess as suggested by @OmerGafny
My problem is I dont know where to add it. The htaccess file has 126 lines and i dont know where exactly to add it

hi @dannyogolo
Try to place it in the

IfModule mod_header.c

section of the htaccess

Is this correct @OmerGafny ?

RewriteEngine On
# Set Authorization header for OAuth1a for when php is running under fcgi
RewriteCond %{HTTP:Authorization} .+
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

# Determine the RewriteBase automatically and set it as environment variable.
# If you are using Apache aliases to do mass virtual hosting or installed the
# project in a subdirectory, the base path will be prepended to allow proper
# resolution of the app.php file and to redirect to the correct URI. It will
# work in environments without path prefix as well, providing a safe, one-size
# fits all solution. But as you do not need it in this case, you can comment
# the following 2 lines to eliminate the overhead.
RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::\2$
RewriteRule ^(.*) - [E=BASE:%1]

# Redirect to URI without front controller to prevent duplicate content
# (with and without `/app.php`). Only do this redirect on the initial
# rewrite by Apache and not on subsequent cycles. Otherwise we would get an
# endless redirect loop (request -> rewrite to front controller ->
# redirect -> request -> ...).
# So in case you get a "too many redirects" error or you always get redirected
# to the start page because your Apache does not expose the REDIRECT_STATUS
# environment variable, you have 2 choices:
# - disable this feature by commenting the following 2 lines or
# - use Apache >= 2.3.9 and replace all L flags by END flags and remove the
#   following RewriteCond (best solution)
# header always unset X-Frame-Options
RewriteCond %{ENV:REDIRECT_STATUS} ^$
RewriteRule ^index\.php(/(.*)|$) %{ENV:BASE}/$2 [R=301,L]

# If the requested filename exists, simply serve it.
# We only want to let Apache serve files and not directories.
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule .? - [L]

# Rewrite all other queries to the front controller.
RewriteRule .? %{ENV:BASE}/index.php [L]

If its not, kindly tell me where exactly within this place you pointed out.

Also, How do I Restart the Server?

I think this is the location.
If you have Apache, you restart it with:
sudo service apache2 restart

I did the commenting
My hosting support did the Apache restart for me

But still hanging on PLEASE WAIT

Ok, if youre on shared hosting, i would suggest also bring this up with them. Maybe its a firewall issue

I got some assistance from Hosting support, but the problem is still there.
He has checked and according to him the server Firewall is not blocking the form.
But it still hangs with the current set of directives added to the .htaccess files.

I am still eager for further assistance

Any more ideas plsssss i am still stuck here ?

Hi, next logical step would be to check the logs. Can you see any entries in connection with this?

Also: are you in control of https://onemailserver.pro/ ? Is that on the same server? Is it possible, that the server where onemailserver.pro is has some WPfence protection?

Also: you are using a popup maker embedded into a wp site (which also uses ninjaforms) where you added the mautic form in the popup. Too many dependencies, maybe make it simple? Why the “click here”?

Unrelated comment: your images are could be better resolution. The own is especially pixelated.

Which logs? WordPress or Mautic?
If I know what to look out for, then I will check.

About onemailserver, YES I am in control. that is where i installed mautic which serves all my websites.
It is on the same shared hosting with namecheap.

As it is now, the site in question is:
a WordPress site
with Popupmaker plugin
the form inside the popup plugin is mautic form
Yes, I have Ninja form on the same site (in fact I was using Ninja form on other popups and they are still working, but after a wordpress update, the plugin that connects the ninja form and mautic crashed and the owner is not updating it again. Old connections still work, but i cant setup new connections. SO due to that, I had to go back to use Mautic own form on this particular page/popup.

So you suggesting I just place the form straight without hiding it inside a popup?

For Bitnamic Mautic 3.1 I had the same issue when I Inspect in Chrome.
I had to add the http(s) sites to CORS as mentioned earlier. Also, I had to comment these two lines out in the httpd.conf then restart Apache. So it’s probably all this. You can do a recusive grep -R “X-Frame” * I believe to find all files but it was just the httpd.conf I had to change.
**** To fix modify httpd.conf and comment out these lines
Header always setifempty X-Frame-Options SAMEORIGIN
Header always merge X-Frame-Options SAMEORIGIN


Hi,
For logs go to your mautic folder /app/logs subfolder.
Post it here, we can take a look and help.
J