Mautic Community Forums

Form is not redirecting every time.

I am facing an issue where forms are not redirecting to thank you page every time. I am using mautic tool from URL http://XYZ.maytic.net instead of hosting it. I noticed console error which were mentioned below, given by chrome. Please help me to resolve an issue so that I may ensure that form redirection will be working every time.

Also, I have been using forms by JS and API and facing error in both cases.

Chrome Error Report -
Uncaught DOMException: Blocked a frame with origin “https://XYZ.mautic.net” from accessing a cross-origin frame.
at HTMLDocument. (https://XYZ.mautic.net/mautic/media/js/app.js?v98398b0d:229:68)
at fire (https://XYZ.mautic.net/mautic/media/js/libraries.js?v98398b0d:328:299)
at Object.fireWith [as resolveWith] (https://XYZ.mautic.net/mautic/media/js/libraries.js?v98398b0d:333:198)
at Function.ready (https://XYZ.mautic.net/mautic/media/js/libraries.js?v98398b0d:340:11)
at HTMLDocument.completed (https://XYZ.mautic.net/mautic/media/js/libraries.js?v98398b0d:340:291)

XYZ is used at place of my domain name.

Hello Guys

I would seriously appreciate some help related to my query. i am able to use API but during insert of a lead into mautic it simply says please wait and form results do not get into mautic.

I have mentioned results of debugging above, so if someone can point me in right direction, it will be great

YOU HAVE Redirection issue with landing page as i am understanding ?

No, I have the issue sometimes page shows “please wait…” for a long time and that time I don’t get leads in the Mautic. This is the main issue.

@mycloud this is your server issue.

My Mautic forms NEVER redirect. It just hangs on “Please wait”. But it does add the contact every time. It used to work fine but now none of my forms work. I even did a clean install - still the same behavior. No error messages. Nothing in the log. Mautic forms simply sit there with “Please wait”. Upgraded to 2.12.1 - no difference. Checked that my urls are correct - they are. Tried manual copy to a non-mautic landing page - still hangs.

Perhaps it is a server issue, but it was working before and now it is not. After searching days for a solution, I am still clueless. Is there a step-by-step troubleshooting guide for this issue?

@jim did you check server log also.

Clear the app/cache every time you change some value there though.

I finally found the solution. It involved modifying two files, mautic-form.js and mautic-form-src.js.

Details are here: https://github.com/mautic/mautic/pull/4656]https://github.com/mautic/mautic/pull/4656

Hello Jim,

Thanks for sharing reference.

But, I have been using mautic at cloud server and suggested solution will help only if muatic is hosted at own server.

Yes, you can’t fix something you can’t get to. It seems as though it should have been fixed in the source code by now since it has been an issue through several upgrades now.

Hold on please wait....not redirecting

Can any one let me know your Any form submit button is working or it is holding at please wait…

This problem is coming in 2,11.0 , 2.12.0, 2.12.1 mautic version…

Yup I have the same problem and have had it for multiple versions now. Persistent and becoming a deal breaker with Mautic

@RonM can you let me know , where you install mautic , Because This problem is coming when you install on mautic at directory like wwww.mydomain.com/mautic … not in domain or sub domain install.

I have found a temp solution - use the manual HTML form code on your site rather than the auto java script form code. Looking at Github there seems to be a fix coming in v 2.12.2

@bizcrony My mautic is installed at www.mydomain.com/nameofclientsmauticinstance

In layman’s terms, where should I move it to solve the problem, and how do I move it?

Yes that could be a temporary solution but not a permanent.

Hello Guys,

I would seriously appreciate some help related to my query.

Thanks in advance.

I have still the same problem with the form.

after pressing the send button its still waiting text. The Lead comes to DB.

I am using 2.13.1

I make this https://mautic.com/help/forms-hanging/ and its not working. After restart the complete Server it works.

So why is there a bebuild function for the forms?

@fidelio you are testing in your mautic or on your website , can you share the link of website form?

@fidelio can you make a vedio and share the link please.