Fresh Mautic 3 install but trouble enabling Zapier, emptying cache, etc

Hello,

Installation was a breeze. No problems with the basic settings either.
But now it comes down to specifics: Zapier integration: I followed the steps, but I cannont get passed the " Allow Zapier to access your MauticAccount?" screen:

We hit an error adding your new account

authentication failed: Requested URL not found: /mtc/api/contacts?limit=1&minimal=1

I also tried enabling LinkedIn, no luck there either – though I did read that that is a bug and we’re waiting for an API upgrade to v2.

I also tried activating the 2FA community plugin – no luck there either. It’s not even found.

“Clean up the cache” is what is recommended. But cache is not inside /apps it’s now inside /var and when I nuke the directory, the whole installation goes down.
“Cleaning from console” , ok console is now in /bin so I SSH and execute php bin/console cache:clear

DANG!

// Clearing the cache for the prod environment with debug false

In ClassExistenceResource.php line 181:

Class “Mautic\CoreBundle\EventListener\CommonSubscriber” not found while loading “MauticPlugin\Hostnet
AuthBundle\EventListener\UserSubscriber”.

I’m almost bald from pulling my hair! Please hlpe me out Mautic gurus?

Cheers,
Erwin

LinkedIn indeed will not work at present.

2FA community plugin I don’t know about - can you give more detail? What plugin are you referring to? If it is the one below, possibly it does not support Mautic 3 yet.

Clean the cache causing the instance to go down - this is almost always a permissions issue where the folder cannot be recreated - see https://docs.mautic.org/en/troubleshooting/file-ownership-and-permissions.

This does not seem familiar to me - is this a third party plugin you are trying to use? If so, entirely possible it is not Mautic 3 compatible?

Hi Ruth,

Thanks for your swift reply, I appreciate your help.
The 2FA plugin is a Google Authenticator plugin (the folder is named AuthBundle).


The last development was 2 years ago according to Github.
I did contact the creator, but haven’t heard back (yet).

Your suspicions were correct, when I removed the plugin the error when trying to clean the cache disappeared :slight_smile:
Though I must say that the documentation needs an update, because I could only clean cache from the console and not by deleting the contents of the cache folder.

Now that this is solved, I still am looking for some login security. I’ve looked into the SAML SSO Settings but cannot figure out how to use it. :frowning:

Any pointers would be helpful.

Cheers,
Erwin

Erwin,
Did this problem get resolved? I seem to have the same issue with connecting Zapier with Mautic v3.1.2

I installed Mautic3 fresh because I had a problem with Mautic 2.16.x which was very similar but I thought the culprit was the older version.

I appreciate any information you can provide.

Best regards,
Caston

Hi Caston,
No unfortunately it’s not solved. The author wrote on GitHub that he is “currently working on updating these plugins. It shouldn’t take long.”
But that was 4 months ago…

Wow… Thanks for the update. By any chance did you have an earlier version of Mautic which worked with Zapier, if so, which version?

I appreciate your time.

Caston

Erwin,
Quick question, Do you think that it is possible that Mautic has changed their strategy and has disabled the Zapier integration with self hosted installs? I have been reviewing the threads and its seems that self-hosting is a consistent problem with those working with Zapier.
Want to see if you have observed this.

Thanks,
Caston

No sorry, no earlier versions.

Uhm I thought your question was about the 2FA plugin. Zapier didn’t work with LinkedIn, I don’t know if that has been fixed/updated to v2 of the LinkedIn API.

Any news about this error Zapier-Mautic? I´m having the same issue

I’m having this issue – anybody know if this got resolved?