Mautic integration trouble with Zapier


Your software
My Mautic version is: V3.3.3
My PHP version is: 7.3.27
My Database type and version is: 2020.4

Your problem
My problem is: integration with Zapier

These errors are showing in the log: We hit an error adding your new account authentication failed: maximum redirect reached at: https://marketing.qosil.app/api/contacts/
Make sure you click “Allow” or “Accept” on the permission popup Double check your Account has the correct permissions Check out our help docs for more information

Steps I have tried to fix the problem:

  1. I already set API enabled? to Yes. Set Enable HTTP basic auth? to Yes.
  2. I connected with Zapier support but we stopped in the moment when I could’t add URL Root because this field doesn’t accept any url and just shows "No matches found

    "

Hi,
After enabling Basic Auth in Mautic you need to clear the cache.
Otherwise it won’t work.

Joey

Yes I did, but it still not works

Okay, how did you clear cache?

1 Like

Develop → Clear cache
as here How to Clear Safari's Cache - MacRumors

Not safari cache.
Mautic cache.

  1. SSH to your server
  2. Navigate to your Mautic instance folder
  3. Type: php bin/console cache:clear

can you please write it step by step?

I can’t unless I EXACTLY know your operation system, where your software is installed, what webserver you have.

Mautic at this point needs command line actions from time to time. I suggest to get familiar with basic commands like finding your installation folder on the server, execute console commands.

PERFECT!!! Tks!

Hi!
I cleared the cache but then system went down. So we solved a lot issues but still system was wenting down after cache clearing and we reinstalled Mautic. After making all the steps again, Zapier integration still doesn’t work. What to do?

Can you plz confirm, that you cleared the cache after turning on basic auth?

Yes I did. Confiming

Ok, can you plz show where relevant error? Is it the same as before?

Yes the same error

Ok, it’s time for someone else to chime in then.