Mautic Community Forums

Zapier Integration Error #404

It seems as though I am getting the error “Looks like I encountered an error (error #404). If I do it again, please report me to the system administrator!” anytime I try and connect my Mautic self hosted version 2.9.

I’ve already Enabled the Mautic API and HTTP Basic Auth in Configuration > API Settings.

What am I doing wrong? I’ve already verified my username and password is working.

Have you double-checked that you’re using the most recent version of the Mautic Zapier app? There’s been some confusion about which one is most current; right now it’s 1.0.3.

I’ve found that this is the best place to confirm the requirements and also get the latest app: https://github.com/mautic/mautic-zapier#zapier-app-for-connecting-mautic

Thanks for the reply Chris. I’ve tried the latest, even from the github link you’ve graciously provided with no luck.

I’ve reviewed the requirements and have run multiple instances of Mautic from v2.9.1 to v2.12.1 and none have worked.

I’ve made sure all the instances have SSL certificates and that I’ve enabled the Mautic API and HTTP Basic Auth in Configuration > API Settings.

I’m not sure what I maybe missing or if this integration still functions. Any further help would be appreciated.

Hmm, I’m not sure what the issue would be then. I’m using the integration without issue, so I don’t think it’s broken - although you certainly could be encountering a bug. Hopefully someone else will have other troubleshooting ideas for you.

UPDATE: I was going through the thread https://github.com/mautic/mautic-zapier/issues/2 and it seems as though clearing the cache under app/cache resolved the issue.

Hopefully this will come in handy for anyone who has this same issue. Again, thanks for the help Chris.

Glad you figured it out! Clearing the cache is always a good move for troubleshooting in general with Mautic :smiley:

I also was able to get this working by clearing the cache.

Is there any way to update the Mautic 1.0.3 Zapier Integration to include more actions then just creating a new contact? Like updating tags for further automation?

If not - how can I write a URL based api expression - I can’t find documentation on this anywhere?
Preferably a simple http auth one.

Thanks!

@eddie for that you need to upgrade mautic before.

I’m still having this issue and tried all the steps above.

I found and fixed the issue. When I setup the Zapier connection to my Mautic site, I left the trailing “/” on the site URL. Once I removed that, it’s working.

I’m having the error when trying to add a segment in the zap after adding the contact. I’m surprised that the zapier doesn’t pull in the current segments. In fact the current zapier still calls them “Mautic Lead Lists”. I tried all the other versions of Mautic inside Zapier (even the depricated ones) and there’s only one that allows for adding Segments. Thoughts?

Thanks @cirrusflyer, that trailing slash seemed to solve my problem too.

For anyone also struggling with Mautic - Zappier connection problem here’s the summary of my solution:

  1. Go to Mautic dashboard Configuration > API Settings and enable the Mautic API and HTTP Basic Auth.
  2. Go to your server with your Mautic installation. Go to “app” folder and delete the “cache” folder. Don’t worry, Mautic will recreate a new one.
  3. Go to Zapier and make a connection. Be sure to delete the trailing slash “/” on your Mautic Base URL.