Mautic Community Forums

HELP! Thriveleads API is not populating contact segments/list

Hi there please I need help :)



I have successfully connect Mautic to thrive leads using the API.

However when I am in thrive leads and try to connect via the mautic API my segments are not displayed please refer to attached or link below

https://www.screencast.com/t/Tj0fvweV8haL





I am running mautic v2.5.2-dev

I am using oAuth2 for connection



My API Setting

Access token lifetime (in minutes) 60

Refresh token lifetime (in days) 999



Thanks a million




Ok 2 things:

  1. To fix the segment not showing up in TL delete your /mautic/app/cache folder. Yes delete it. Trust me, it will be regenerated again right after. That fixes it (press the reload icon in Thrive). I had the same issue yesterday and that’s how I solved it.

P.S. deleting the cache folder is a good trouble shooting tactic in Mautic in general.

  1. Don’t use oAuth2, use oAuth / oAuth1. Because oAuth2 requires you to re-authenticate periodically. No problem if you don’t mind, but if not necessary it’s just a hassle.

Please send the million to PO box 501, thanks :slight_smile:

Hi there please I need help :slight_smile:

I have successfully connect Mautic to thrive leads using the API.
However when I am in thrive leads and try to connect via the mautic API my segments are not displayed please refer to attached or link below
https://www.screencast.com/t/Tj0fvweV8haL

I am running mautic v2.5.2-dev
I am using oAuth2 for connection

My API Setting
Access token lifetime (in minutes) 60
Refresh token lifetime (in days) 999

Thanks a million

@Paul999 Thank you very very much :slight_smile: It worked the segments started populating on TL once I deleted the cache folder thanks.

Also I switched to oAuth1
Enjoy your day

[quote=19555:@Paul999]Ok 2 things:

  1. To fix the segment not showing up in TL delete your /mautic/app/cache folder. Yes delete it. Trust me, it will be regenerated again right after. That fixes it (press the reload icon in Thrive). I had the same issue yesterday and that’s how I solved it.

P.S. deleting the cache folder is a good trouble shooting tactic in Mautic in general.

  1. Don’t use oAuth2, use oAuth / oAuth1. Because oAuth2 requires you to re-authenticate periodically. No problem if you don’t mind, but if not necessary it’s just a hassle.

Please send the million to PO box 501, thanks :)[/quote]

This did the job for me :slight_smile: