Mautic Community Forums

How to serve first party cookies with Mautic - one instance, several domains

Yes, you are safe with your setup.

Until the second level domain is the same, there are no issues.

Which is the error? If you don’t post it we cannot know which the problem could be.

Are you sure dns are correctly propagated? Did you created a correct ssl certificate for ma.domain-b.com? Can you access Mautic going to ma.domain-b.com?

Mautic is installed at messaging.allthingscoos.com.

The wordpress site in question is https://coosguide.com. NOTE: the tracking script is only located on the homepage for testing purposes, it’s not in the header at the moment.

The CNAME is set up to point messaging.coosguide.com to messaging.allthingscoos.com

I can access my Mautic install at messaging.coosguide.com, so the DNS seems to be fine.

I verified that messaging.coosguide.com and messaging.allthingscoos.com are both SANs in the certificate.

From the Google Chrome console

A cookie associated with a cross-site resource at https://messaging.allthingscoos.com/ was set without the SameSiteattribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set withSameSite=NoneandSecure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at https://www.chromestatus.com/feature/5088147346030592 and https://www.chromestatus.com/feature/5633521622188032.

If I edit the URL Field under Settings > URL to "messaging.coosguide.com, then the issue goes away (but of course it would break it on the other site).

Which version of Mautic are you running?

Current Mautic version is 2.16.3

The only thing I can come up with is somewhere messaging.allthingscoos.com (the actual domain of the mautic install) should be rewritten to messaging.coosguide.com (the cname).