How to upgrade from 4.4.10 to 5.0.3?

Where can i find an instruction how to correctly update Mautic 4.4.10 to 5.0.3?
Don’t know if the the way described in the Mautic manual is up to date.

I saw Mautics Browser alert, that i can update via Browser.
Does that working with 5.0.3?

Generally: Is Mautic 5.0.3 ready to use in business or still too buggy?

1 Like

Don’t use the browser update, it will fail.
If it’s buggy? There are certain issues, please read the announcements and the blog to decide if it has all the features you need for your particular case, especially if you use Amazon SES and transactional emails.

Where can I find a instructon for update to 5.0.3?

What Email SMTP do you use?

Just pitching in since I find myself in this same scenario. I am using Amazon SES for SMTP and am hoping to get outbox monitoring with SNS working after this. Is there a reason NOT to upgrade if we are using AWS SES?

Thanks in advance @joeyk !

Hi, there is no feedback loop callback at the momment. We are working on it, I think max 1-2 weeks.

Let me ask again: Where is a current instruction how to install Mautic 5.x
I know, that it useful to wait at least to 5.0.4 for updating.

1 Like

Hello, I there is no one document which you can use, and I could recommend. I will produce one when I tested with at least 10 successful upgrades and I will be convinced all the obsticles are gone for me to upgrade, and Mautic is 100% safe to use for end user. For example the bug is fixed where you can accidently send an email to bounced contacts. And when there is a perfectly working aws feedback loop.

Until then I think its better to focus on testing / fixing PRs then writing an article on the upgrade.


So this means, Mautic 5 is not ready with version 5.0.3? We should not upgrade from 4.4.x?

1 Like

Don’t upgrade it to 5.0.3
You see many issues: Issues · mautic/mautic · GitHub

I’ll wait until 5.1.x - and look tho the issues…after 5.1.0 i can update php8.0 to 8.2 and i think before there are to many errors.

1 Like

@joeyk I am still unable to download the update for Mautic for my company

I’m not sure how to respond to this. Can you ellaborate?

i downloaded the file for version and i got this error message ‘php’ is not recognized as an internal or external command,
operable program or batch file. when i tried running it

Didcyou download it on your laptop?

HEllo, I have 4.4.11 somehow damaged since I cannot load settings page.
I hope by upgrade to fix this too.
Could you please post the steps for upgrade ? I understood that’s CLI.
Thank you,

Here is how to update: How to update Mautic — Mautic Documentation 0.1 documentation

Only over command line is my advice. That worked for me.