HTML Email Templates ALL Show up Blank in Editor/Builder

Your software
My PHP version is : v7.3
My MySQL/MariaDB version is
MariaDB version 10.3.25

Updating/Installing Errors

Upgrading/installing via (delete as applicable) : Web / Command Line

OS: Linux Ubuntu 20.04
Mautic Version: v3.1.2
Method of Installation: command line/terminal

Your problem

The problem is that I try to select an HTML template for sending a test email to myself, and when trying to edit the template in the “Builder”, everything is blank. There is no template available to edit in the Builder/editor, even after clearly selecting a template (tried selecting multiple templates & still all blank).

Here’s what it’s looking like after trying to select an HTMl template to edit:

It seems like I may be missing a package during installation, but not quite sure. Any ideas?

Any support is greatly appreciated.

So, I managed to get the HTML working again by using the following commands:

chown -R www-data:www-data /var/www/html
chmod -R 775 /var/www/html

BUT, now the images do not show up.

After looking in the Google Chrome “Developer tools”, I can see a bunch of “404 error” messages in the console. Here’s what the error messages look like:

It seems to be some error with the redirect. Even the HTML “email preview” page is completely blank after clicking on the “preview” button. HTML not blank in the 'Builder" (editor),but the whole template HTML & images are completely blank.

You can try clearing cache.

Also have a look at the Mautic log for clues about what is going on. It’s at /var/www/html/var/logs/

Thank you for your response. Yeah, I’ve already tried clearing the cache and actually already have a cron job doing some cleanup. Logs aren’t showing anything either, only the browser is showing the 404 errors.

BTW, I am using NGINX and I’m wondering if it has anything to do with the server block.

Also, I know that it has something to do with connecting to the ‘/var/www/mautic/themes’ folder. The images in this folder are the ones that do not show up, only the html & css.

Any other ideas of what I need to do to fix this? Like I said, I think it could be NGINX not properly configured to process the redirects for the images, just not 100% sure how to fix it to get the images to load. Thanks again.

One other thing you could try is to re-insert the images. I moved the domain name of one of our Mautic instances recently and the Images Break when you do this. Inserting them again in the email solved this form me. In that case the wrong links where in the email itself and caused errors on my emails

If that does not solve your problem I think you’ll do well to check your Ngnix config.
Try the Ngnix Forums and check back here once you’re happy that end works as expected.

Thanks Codes9! Yeah, images worked after uploading my own. This is actually more of a workaround instead of a direct fix. I don’t know if this is a bug in Mautic or something misconfigured in nginx. Anyhow, I’ve decided to mark this as the solution because it still solves the problem of not having broken images, but it would still be nice to not have this problem straight out of the box after installation. Thanks again though.

1 Like