Mautic Community Forums

Images in emails - Code Mode

Issue: Images not showing in emails sent using code mode. Mautic v2.9.0-dev.

I set up a new email, using code mode. Cut & Paste the html, everything looks good in the preview panel, all images showing. Sent the email, images not showing at all, image src has been stripped but the rest of its attributes (width, etc) are still there.



I REALLY don’t want to have to use the Mautic media library for many reasons, not least that the emails we’re sending have a lot of responsive code that I’m guessing Mautic will strip. Plus, my team aren’t 100% tech-savvy.



Any ideas how to fix/get around this please?

Issue: Images not showing in emails sent using code mode. Mautic v2.9.0-dev.
I set up a new email, using code mode. Cut & Paste the html, everything looks good in the preview panel, all images showing. Sent the email, images not showing at all, image src has been stripped but the rest of its attributes (width, etc) are still there.

I REALLY don’t want to have to use the Mautic media library for many reasons, not least that the emails we’re sending have a lot of responsive code that I’m guessing Mautic will strip. Plus, my team aren’t 100% tech-savvy.

Any ideas how to fix/get around this please?

UPDATE: It still fails if I use urls of images uploaded to the Mautic Media library.

UPDATE TWO: If I create a test email from one of the sample themes and don’t touch any of the code or design, the images in the builder are broken. I do a preview (https://mautic.processflows.co.uk/email/preview/3), then look at the source url for the image (https://mautic.processflows.co.uk/index.php/themes/neopolitan/img/robomail.gif), it has added the index.php after the main url, take that index.php/ out and the image shows.

UPDATE THREE: Site url was set to https://mautic.processflows.co.uk/index.php - have removed the index.php, now preview of emails works fine, but images still broken in sent emails.

UPDATE FOUR: Site url set to https://mautic.processflows.co.uk (no trailing forward-slash), images still broken in received emails

EXAMPLE: Preview: https://mautic.processflows.co.uk/email/preview/5 - HTML in received email has this for the img code for the robot image: robot picture - NO SRC !!!

FIXED !!!

Turn off ‘Convert embed images to Base64’ in Configuration>Email Settings