Information about Mautic 5 composer install - error 500 in "step 2"

Your software
My Mautic version is: 5.0.0
My PHP version is: 8.0
My Database type and version is: MariaDB 10.3.38

Your problem
My problem is:

When installing Mautic 5 (download zip from repo, composer install…) the following setup process breaks in step 2 with Error 500.

These errors are showing in the log:

[2023-04-15 11:05:54] mautic.WARNING: PHP Warning - require(/var/www/vhosts/placeholder1/ Failed to open stream: No such file or directory - in file /var/www/vhosts/placeholder1/ - at line 197 {“hostname”:“placeholder2”,“pid”:3895036}
[2023-04-15 11:05:54] mautic.CRITICAL: Uncaught PHP Exception Error: “Failed opening required ‘/var/www/vhosts/placeholder1/’ (include_path=‘.:/opt/plesk/php/8.0/share/pear’)” at /var/www/vhosts/placeholder1/ line 197 {“exception”:“[object] (Error(code: 0): Failed opening required ‘/var/www/vhosts/placeholder1/’ (include_path=‘.:/opt/plesk/php/8.0/share/pear’) at /var/www/vhosts/placeholder1/”} {“hostname”:“placeholder2”,“pid”:3895036}

Steps I have tried to fix the problem:
As the composer ended with some error relateg to mautic:assets:generate, I ran it sucessfully after the composer install. It might only be an indicator, but it wasn’t the reason.

Clearing the cache solved the issue. Probably something is broken with the cache generation? It seems to have been generated at composer installation, at least before the step2 was reached in the setup process (based on timestamps).

Should this be an issue in github?