Mautic Community Forums

Installation Error With Specific Steps and Troubleshooting

Good day all. I’m excited to get started with Mautic, but ran into my first hurdle. I attempted searching the forums for similar issues, but the solutions I found were not working for me. Please bare with me as I’m new to the VPS world and Linux, so all of this has been a learning experience. I have learned a great deal installing various other solutions I’m using, and this is one of the final pieces.



I’ve uploaded all relevant files, and unzipped. When I run the online installer, my server passes the initial check. I complete all details and then click next step. It seems to start working, and then I am directed to a page stating “Internal Server Error”.



Reviewing my server logs, I see the error “mod_fcgid: read data timeout in 40 seconds”. Searching and searching, I modified a few configurations. In the PHP.ini file, I updated the max_execution time to 300 from 30, and also the memory limit to 256M as discovered somewhere else. I also changed PHP script run time to 0 in the website options panel of Virtual Min (running on Ubuntu 16). Restarted Apache and MySQL like 5 times each.



I keep getting stopped at the same point in the install.



Can someone help to direct me in the right direction? I’m sure it is something simple that I’m overlooking.



Thanks a lot!

Good day all. I’m excited to get started with Mautic, but ran into my first hurdle. I attempted searching the forums for similar issues, but the solutions I found were not working for me. Please bare with me as I’m new to the VPS world and Linux, so all of this has been a learning experience. I have learned a great deal installing various other solutions I’m using, and this is one of the final pieces.

I’ve uploaded all relevant files, and unzipped. When I run the online installer, my server passes the initial check. I complete all details and then click next step. It seems to start working, and then I am directed to a page stating “Internal Server Error”.

Reviewing my server logs, I see the error “mod_fcgid: read data timeout in 40 seconds”. Searching and searching, I modified a few configurations. In the PHP.ini file, I updated the max_execution time to 300 from 30, and also the memory limit to 256M as discovered somewhere else. I also changed PHP script run time to 0 in the website options panel of Virtual Min (running on Ubuntu 16). Restarted Apache and MySQL like 5 times each.

I keep getting stopped at the same point in the install.

Can someone help to direct me in the right direction? I’m sure it is something simple that I’m overlooking.

Thanks a lot!

After hundreds of varied attempts, I found a solution that worked for me. Hopefully it’ll help someone else.

Within Virtualmin/Webmin, I went to the Webmin menu --> Servers --> Apache Webserver --> Edit Config Files

At the bottom of that config file I inserted:

IPCConnectTimeout 20
IPCCommTimeout 300

Saved and closed the file. Restarted Apache.

The install went through, and I’m all set up. My first test email went through without issue!