Mautic Community Forums

504 gateway timeout when login in

Your software
My Mautic version is: 3.0.1
My PHP version is: 7.2

Your problem
My problem is: 504 gateway timeout

These errors are showing in the log: no

Steps I have tried to fix the problem: change php.ini

I have a 504 gateway time out every time I try to access mautic and click the login button. My mutic version is 3.0.1.

Can you help me please?

I’ve noticed that login takes around 10 seconds on my Mautic 3.0.1. I guess this is a protection against brute forcing the password.

However, 10 seconds may be too long for the the HTTP server to wait for a response from php-fpm. If this assumption is correct, you have to look into your HTTP server configuration (Nginx?) to fix this. My guess is that fastcgi_read_timeout is too low.

Thanks for your help, but how can I change it, I am in cpanel, just I have to add it to php.ini editor mode? wich value must have I to add?

Thanks

I’m not familiar with cPanel. The first thing to do is to determine which HTTP server you’re using: Apache ? Nginx ? and then look for the gateway timeout parameter specific to the server you’re using.