Mautic Community Forums

Installation Error

Its not getting installed, its gives



The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.

System administrators, check server logs for errors.



This comes when i have to create administrator user for it. Please help



Here is what the error log says:



[03-Aug-2017 07:17:28 UTC] PHP Warning: include(/home/arconsultingsols/public_html/arconsulting.co.in/Mautic/vendor/composer/…/psr/log/Psr/Log/LogLevel.php): failed to open stream: No such file or directory in /home/arconsultingsols/public_html/arconsulting.co.in/Mautic/vendor/composer/ClassLoader.php on line 414

[03-Aug-2017 07:17:28 UTC] PHP Warning: include(): Failed opening ‘/home/arconsultingsols/public_html/arconsulting.co.in/Mautic/vendor/composer/…/psr/log/Psr/Log/LogLevel.php’ for inclusion (include_path=’.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php’) in /home/arconsultingsols/public_html/arconsulting.co.in/Mautic/vendor/composer/ClassLoader.php on line 414

[03-Aug-2017 07:17:28 UTC] PHP Fatal error: Class ‘PsrLogLogLevel’ not found in /home/arconsultingsols/public_html/arconsulting.co.in/Mautic/app/bundles/CoreBundle/ErrorHandler/ErrorHandler.php on line 156

[03-Aug-2017 07:23:09 UTC] PHP Warning: require(/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php): failed to open stream: No such file or directory in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209

[03-Aug-2017 07:23:09 UTC] PHP Fatal error: require(): Failed opening required ‘/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php’ (include_path=’.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php’) in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209

[03-Aug-2017 07:25:38 UTC] PHP Warning: require(/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php): failed to open stream: No such file or directory in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209

[03-Aug-2017 07:25:38 UTC] PHP Fatal error: require(): Failed opening required ‘/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php’ (include_path=’.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php’) in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209

[03-Aug-2017 07:31:35 UTC] PHP Warning: require(/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php): failed to open stream: No such file or directory in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209

[03-Aug-2017 07:31:35 UTC] PHP Fatal error: require(): Failed opening required ‘/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php’ (include_path=’.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php’) in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209

[03-Aug-2017 07:40:10 UTC] PHP Warning: require(/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php): failed to open stream: No such file or directory in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209

[03-Aug-2017 07:40:10 UTC] PHP Fatal error: require(): Failed opening required ‘/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php’ (include_path=’.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php’) in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209

Its not getting installed, its gives

The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.
System administrators, check server logs for errors.

This comes when i have to create administrator user for it. Please help

Here is what the error log says:

[03-Aug-2017 07:17:28 UTC] PHP Warning: include(/home/arconsultingsols/public_html/arconsulting.co.in/Mautic/vendor/composer/…/psr/log/Psr/Log/LogLevel.php): failed to open stream: No such file or directory in /home/arconsultingsols/public_html/arconsulting.co.in/Mautic/vendor/composer/ClassLoader.php on line 414
[03-Aug-2017 07:17:28 UTC] PHP Warning: include(): Failed opening ‘/home/arconsultingsols/public_html/arconsulting.co.in/Mautic/vendor/composer/…/psr/log/Psr/Log/LogLevel.php’ for inclusion (include_path=’.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php’) in /home/arconsultingsols/public_html/arconsulting.co.in/Mautic/vendor/composer/ClassLoader.php on line 414
[03-Aug-2017 07:17:28 UTC] PHP Fatal error: Class ‘PsrLogLogLevel’ not found in /home/arconsultingsols/public_html/arconsulting.co.in/Mautic/app/bundles/CoreBundle/ErrorHandler/ErrorHandler.php on line 156
[03-Aug-2017 07:23:09 UTC] PHP Warning: require(/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php): failed to open stream: No such file or directory in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209
[03-Aug-2017 07:23:09 UTC] PHP Fatal error: require(): Failed opening required ‘/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php’ (include_path=’.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php’) in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209
[03-Aug-2017 07:25:38 UTC] PHP Warning: require(/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php): failed to open stream: No such file or directory in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209
[03-Aug-2017 07:25:38 UTC] PHP Fatal error: require(): Failed opening required ‘/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php’ (include_path=’.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php’) in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209
[03-Aug-2017 07:31:35 UTC] PHP Warning: require(/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php): failed to open stream: No such file or directory in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209
[03-Aug-2017 07:31:35 UTC] PHP Fatal error: require(): Failed opening required ‘/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php’ (include_path=’.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php’) in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209
[03-Aug-2017 07:40:10 UTC] PHP Warning: require(/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php): failed to open stream: No such file or directory in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209
[03-Aug-2017 07:40:10 UTC] PHP Fatal error: require(): Failed opening required ‘/home/arconsultingsols/public_html/arconsulting.co.in/mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticUserBundleEntityRole.php’ (include_path=’.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php’) in /home/arconsultingsols/public_html/arconsulting.co.in/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209

Can i anybbody help, please ??

Same Here.
i have created new custom plugin and when i was trying to install that plugin then i getting this error.

---------------> mautic log file errors

[2017-08-14 05:54:32] mautic.WARNING: PHP Warning - require(/var/www/html/10_08_17_mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php): failed to open stream: No such file or directory - in file /var/www/html/10_08_17_mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []

[2017-08-14 05:54:32] mautic.ERROR: PHP Notice: require(): Failed opening required ‘/var/www/html/10_08_17_mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php’ (include_path=’.:/usr/share/php’) - in file /var/www/html/10_08_17_mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []

[2017-08-14 05:54:32] mautic.ERROR: SymfonyComponentDebugExceptionFatalErrorException: Notice: require(): Failed opening required ‘/var/www/html/10_08_17_mautic/app/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php’ (include_path=’.:/usr/share/php’) - in file /var/www/html/10_08_17_mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []

------------> And in Server log error file

[Mon Aug 14 11:24:41.603879 2017] [:error] [pid 8127] [client 127.0.0.1:39906] PHP Warning: Declaration of MauticPlugin\HelloWorldBundle\HelloWorldBundle::onPluginInstall(MauticPlugin\HelloWorldBundle\Plugin $plugin, MauticPlugin\HelloWorldBundle\MauticFactory $factory, $metadata = NULL) should be compatible with Mautic\PluginBundle\Bundle\PluginBundleBase::onPluginInstall(Mautic\PluginBundle\Entity\Plugin $plugin, Mautic\CoreBundle\Factory\MauticFactory $factory, $metadata = NULL, $installedSchema = NULL) in /var/www/html/10_08_17_mautic/plugins/HelloWorldBundle/HelloWorldBundle.php on line 0, referer: http://localhost/10_08_17_mautic/s/update/schema

[Mon Aug 14 11:24:41.604147 2017] [:error] [pid 8127] [client 127.0.0.1:39906] PHP Warning - Declaration of MauticPlugin\HelloWorldBundle\HelloWorldBundle::onPluginUpdate(MauticPlugin\HelloWorldBundle\Plugin $plugin, MauticPlugin\HelloWorldBundle\MauticFactory $factory, $metadata = NULL, MauticPlugin\HelloWorldBundle\Schema $installedSchema = NULL) should be compatible with Mautic\PluginBundle\Bundle\PluginBundleBase::onPluginUpdate(Mautic\PluginBundle\Entity\Plugin $plugin, Mautic\CoreBundle\Factory\MauticFactory $factory, $metadata = NULL, Doctrine\DBAL\Schema\Schema $installedSchema = NULL) - in file /var/www/html/10_08_17_mautic/plugins/HelloWorldBundle/HelloWorldBundle.php - at line 0, referer: http://localhost/10_08_17_mautic/s/update/schema

[Mon Aug 14 11:24:41.604269 2017] [:error] [pid 8127] [client 127.0.0.1:39906] PHP Warning: Declaration of MauticPlugin\HelloWorldBundle\HelloWorldBundle::onPluginUpdate(MauticPlugin\HelloWorldBundle\Plugin $plugin, MauticPlugin\HelloWorldBundle\MauticFactory $factory, $metadata = NULL, MauticPlugin\HelloWorldBundle\Schema $installedSchema = NULL) should be compatible with Mautic\PluginBundle\Bundle\PluginBundleBase::onPluginUpdate(Mautic\PluginBundle\Entity\Plugin $plugin, Mautic\CoreBundle\Factory\MauticFactory $factory, $metadata = NULL, Doctrine\DBAL\Schema\Schema $installedSchema = NULL) in /var/www/html/10_08_17_mautic/plugins/HelloWorldBundle/HelloWorldBundle.php on line 0, referer: http://localhost/10_08_17_mautic/s/update/schema