Mautic Community Forums

Installation problem "The site is currently offline ..."

Hi,
I’m installing Mautic and after step 1 where is database info (/installer/step/1.1) this happens: “The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator. System administrators, check server logs for errors.”. I’m stuck and have no idea what to do next. All requirements are ok: php7, mysql engine is innoDB, Apache.
Also i got error log:
Got error ‘Passing INI directive through FastCGI: unable to set ‘always_populate_raw_post_data’\nPHP message: Symfony\Component\DependencyInjection\Exception\ParameterNotFoundException: You have requested a non-existent parameter “37”. - in file /home/servername/ftp/mautic/vendor/symfony/dependency-injection/ParameterBag/ParameterBag.php - at line 84\n’, referer: http://servername.com/mautic/installer/step/1
and:
Got error ‘Passing INI directive through FastCGI: unable to set ‘always_populate_raw_post_data’\n’, referer: http://servername.com/mautic/installer/step/1
Can anyone help me, please?
Thank you

Hi,
thank you for reply. I have hosted srver, so I can’t edit php.ini, but I’ve tried adding php_value always_populate_raw_post_data -1 to .htaccess, making .user.ini file with always_populate_raw_post_data = -1, creating php.ini and adding SetEnv PHPRC /home/myservername/php.ini to .htaccess and no effect, still site has “The site is currently offline due to encountering an error.” info.

I deleted prod folder and no difference, “The site is currently offline…” info is still on, and server log is same: “… unable to set ‘always_populate_raw_post_data’…”.
Thank You all for help, I eventually decided to change hosted server to vps, and configure everything properly for mautic.

Square, I have the same problem.
Have you found a solution?

Gustavo, unfortunately I’ve found no solution that worked for me. I changed server to vps, configured everything and now it works. I suppose hosted server is not the best solution for mautic.

Thank you for answering Square :wink:

I have a cloud (server) with cpanel, I have root access in WHM.

I can make whatever modifications are necessary.

I’m making progress. reading log of server, found:
PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 65536 bytes)

Then i changed the memory limit (memory_limit) to 128MB (recommended)

Also, cleared app / cache.

Now I need to enable some extensions that Mautic requires.

I have the same problem.
Have you found a solution?

Verify if the db password contains illegal characters that determines sql injection like ‘?’