Mautic Community Forums

Site Offline

When i finished the installation this message prompt:



The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.



Looking the error_log inside the folder:



#0 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(248): SymfonyComponentDependencyInjectionParameterBagParameterBag->get(‘bteap8’)

#1 [internal function]: SymfonyComponentDependencyInjectionParameterBagParameterBag->SymfonyComponentDependencyInjectionParameterBag{closure}(Array)

#2 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(258): preg_replace_callback(’/%%|%([^%\s]+)%…’, Object(Closure), ‘y%BteAP8%34D’)

#3 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(203): SymfonyComponentDependencyInjectionParameterBagParameterBag->resolveString(‘y%BteAP8%34D’, Array)

#4 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(232): SymfonyComponentDependencyInjectionParameterBagParameterBag->resolveValue(‘y%BteAP8%34D’, Array)

#5 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(203): SymfonyComponentDependencyInjectionParameterBagParameterBag->resolveString(’%mautic.db_pass…’, Array)

#6 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(193): SymfonyComponentDependencyInjectionParameterBagParameterBag->resolveValue(’%mautic.db_pass…’, Array)

#7 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(193): SymfonyComponentDependencyInjectionParameterBagParameterBag->resolveValue(Array, Array)

#8 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(193): SymfonyComponentDependencyInjectionParameterBagParameterBag->resolveValue(Array, Array)

#9 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Compiler/MergeExtensionConfigurationPass.php(45): SymfonyComponentDependencyInjectionParameterBagParameterBag->resolveValue(Array)

#10 /home/tudos698/public_html/mautic/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/DependencyInjection/MergeExtensionConfigurationPass.php(39): SymfonyComponentDependencyInjectionCompilerMergeExtensionConfigurationPass->process(Object(SymfonyComponentDependencyInjectionContainerBuilder))

#11 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Compiler/Compiler.php(117): SymfonyComponentHttpKernelDependencyInjectionMergeExtensionConfigurationPass->process(Object(SymfonyComponentDependencyInjectionContainerBuilder))

#12 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php(614): SymfonyComponentDependencyInjectionCompilerCompiler->compile(Object(SymfonyComponentDependencyInjectionContainerBuilder))

#13 /home/tudos698/public_html/mautic/app/AppKernel.php(489): SymfonyComponentDependencyInjectionContainerBuilder->compile()

#14 /home/tudos698/public_html/mautic/app/AppKernel.php(252): AppKernel->initializeContainer()

#15 /home/tudos698/public_html/mautic/app/AppKernel.php(71): AppKernel->boot()

#16 /home/tudos698/public_html/mautic/index.php(56): AppKernel->handle(Object(SymfonyComponentHttpFoundationRequest))

#17 {main}



What can I do? Any Idea

I reinstalled and worked fine. Tks

When i finished the installation this message prompt:

The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.

Looking the error_log inside the folder:

#0 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(248): SymfonyComponentDependencyInjectionParameterBagParameterBag->get(‘bteap8’)
#1 [internal function]: SymfonyComponentDependencyInjectionParameterBagParameterBag->SymfonyComponentDependencyInjectionParameterBag{closure}(Array)
#2 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(258): preg_replace_callback(’/%%|%([^%\s]+)%…’, Object(Closure), ‘y%BteAP8%34D’)
#3 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(203): SymfonyComponentDependencyInjectionParameterBagParameterBag->resolveString(‘y%BteAP8%34D’, Array)
#4 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(232): SymfonyComponentDependencyInjectionParameterBagParameterBag->resolveValue(‘y%BteAP8%34D’, Array)
#5 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(203): SymfonyComponentDependencyInjectionParameterBagParameterBag->resolveString(’%mautic.db_pass…’, Array)
#6 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(193): SymfonyComponentDependencyInjectionParameterBagParameterBag->resolveValue(’%mautic.db_pass…’, Array)
#7 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(193): SymfonyComponentDependencyInjectionParameterBagParameterBag->resolveValue(Array, Array)
#8 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(193): SymfonyComponentDependencyInjectionParameterBagParameterBag->resolveValue(Array, Array)
#9 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Compiler/MergeExtensionConfigurationPass.php(45): SymfonyComponentDependencyInjectionParameterBagParameterBag->resolveValue(Array)
#10 /home/tudos698/public_html/mautic/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/DependencyInjection/MergeExtensionConfigurationPass.php(39): SymfonyComponentDependencyInjectionCompilerMergeExtensionConfigurationPass->process(Object(SymfonyComponentDependencyInjectionContainerBuilder))
#11 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Compiler/Compiler.php(117): SymfonyComponentHttpKernelDependencyInjectionMergeExtensionConfigurationPass->process(Object(SymfonyComponentDependencyInjectionContainerBuilder))
#12 /home/tudos698/public_html/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php(614): SymfonyComponentDependencyInjectionCompilerCompiler->compile(Object(SymfonyComponentDependencyInjectionContainerBuilder))
#13 /home/tudos698/public_html/mautic/app/AppKernel.php(489): SymfonyComponentDependencyInjectionContainerBuilder->compile()
#14 /home/tudos698/public_html/mautic/app/AppKernel.php(252): AppKernel->initializeContainer()
#15 /home/tudos698/public_html/mautic/app/AppKernel.php(71): AppKernel->boot()
#16 /home/tudos698/public_html/mautic/index.php(56): AppKernel->handle(Object(SymfonyComponentHttpFoundationRequest))
#17 {main}

What can I do? Any Idea

Have you tried to clean the cache folder?

I had very similar errors when trying to manually upgrade Mautic. Clearing the cache folder did not help. Had to revert to a backup.