Issue with Focus Items Builder Page - Web snapshot not showing or page loading

Your software
My Mautic version is: v2.16.2
My PHP version is: 7.2.26

Your problem
My problem is:

I’m looking for a fix or some feedback on the following.

Issue with Focus Items setup in Builder Page - Web snapshot not showing and page failing to load.

Error Page and Message Returned:

Uh oh! I think I broke it. If I do it again, please report me to the system administrator!
500 Internal Server Error

These errors are showing in the log:

[2020-06-13 16:01:43] mautic.CRITICAL: Uncaught PHP Exception RuntimeException: “SSL certificate problem: unable to get local issuer certificate” at /home/hypnolo4/mailer.hypnotherapylocal.com/vendor/joomla/http/src/Transport/Curl.php line 185 {“exception”:"[object] (RuntimeException(code: 0): SSL certificate problem: unable to get local issuer certificate at /home/hypnolo4/mailer.hypnotherapylocal.com/vendor/joomla/http/src/Transport/Curl.php:185)"}

[2020-06-13 16:10:16] mautic.CRITICAL: Uncaught PHP Exception RuntimeException: “SSL certificate problem: unable to get local issuer certificate” at /home/hypnolo4/mailer.hypnotherapylocal.com/vendor/joomla/http/src/Transport/Curl.php line 185 {“exception”:"[object] (RuntimeException(code: 0): SSL certificate problem: unable to get local issuer certificate at /home/hypnolo4/mailer.hypnotherapylocal.com/vendor/joomla/http/src/Transport/Curl.php:185)"}

Steps I have tried to fix the problem:

I have read through the support forum and have noticed that others have experienced some issues with Focus Items. No solution was presented from what I read other than increase PHP memory which I have done. The issue remains.

Is there a fix or pending fix for this?

I welcome your feedback and suggestions.

Thank you.

Hi there, welcome to the forums!

This is a known bug, we have a fix which you can test as follows:

  • Go to m3.mautibox.com and in the dropdown, type the number of the pull request (8894) then select it and click to begin
  • Check that the builder loads (use https://www.example.com if your domain is non-SSL or blocks being previewed - it will show an error if that is the case)
  • If it works fine, go here, click review changes and choose approve!

Thanks in advance for helping us improve Mautic!

Thanks for your prompt reply. Glad to be part of this forum.

Everything worked OK on the test site m3.mautibox.com

Builder loads and web page snapshot loads perfectly.

On the web page at https://github.com/mautic/mautic/pull/8894/files

I’m cannot find where ‘Click Review Changes’ and ‘Choose Approve’
are on the page.

What is the fix that I can implement on my current website?

2 Likes

I wasn’t logged in to https://github.com/mautic/mautic that’s why I didn’t see the above.

There appears to be a lot of file updates related to the Focus Items issue. I take it that these fixes will be in Mautic v3. Will there be fixes for v2.16.2 ?

Thanks again for your help.

2 Likes

Hi Martin,

Thanks for testing that it worked, this is a simple way we can all help with getting bug fixes and new features into the forthcoming releases of Mautic!

The fix needed several files to be changed, which is not unusual.

The 2.x series will only receive security updates from this point on, please take a look at:

So no, there won’t be any fixes for the 2.x series for this issue.

very helpful post. Looking forward to the release of Mautic3. I found that the workaround to getting focus items in 2.x is to simply not include the website in the initial configuration. If you do not do that you will not see any preview, but you will also not get any error messages and can actually go ahead and create the focus item you want.

1 Like

Thanks for the information on Mautic 3 release date.

I’m looking forward to it.

The work around suggested by mikew in this thread worked out for me.

I can continue working with Mautic v2.16.2 until I install the new release.

Cheers.

Hi Mikew,

Thank you for your comment.

Your suggested work around enabled me to use Focus Items in Mautic v2.16.2 but without the web page snap shot or error messages appearing.

Regards,

-Martin

1 Like

good to know that and good to know that I cant update to latest version 3 on shared hosting because of phpmyadmin being too low in version - great job guys

What are you on shared hosting ? Why not move to a dedicated server on Digital Ocean.
If you want, use my link, you will get $100 credit for 2 months.

You can go ahead and install Mautic 3.1.1 and start getting all the updates

how much does it cost per year to run it on digital ocean?
do you use amazon ses for emailing?

depends on your needs, I am able to run a server for $5/month, so for year one it will cost. you $50 as you will get 2 months for free with the $100 credit.

I do not use Amazon SES, I use my own mail servers and SendGrid

that is only cost for digital ocean, i bet sendgrid is expensive much more than SES amazon, am I right?

Sendgrid you can get different deals, how much are you planning on sending per month ?

Basic plan on SendGrid is $14.95 for 40K and $29.95 for 100,000 monthly.

Go over this and you will need to move to a professional plan and you get your own IP - so you better be sending clean :smiley:

why even thinking about it, if amazon ses costs like 5 usd per 100k emails? Why ?

I’m used to using SendGrid and have more leanancy there, but each to their own.

Amazon SES costs $1/10k email = $10/100k