Mautic Community Forums

Label issues

Hello there.



Im sort of a new to Mautic, and after watching several videos, i found myself in a issue involving labels.



In my page, i coded some triggers to add specific labels for mautic’s contacts. And that worked quite fine.



My issue is regarding the campaigns.



Let’s say i have a segment called Newsletter… And then, i setup a campaign for this segment… But the very first check is to check if this contact has a specific label, if does, send an email…



The problem is, mautic only check this label once, when the contact is added to the campaign, and it would be very smart of it, if it re-run this validation everytime something changes on the contact. Let’s say the my contact is not ready to receive some e-mails, but as soon as it gets ready, i’d like it to join the campaign.



Im not sure if this is how mautic works or if is there any other approuch to fix my issue, but i really appreciate any of your help pointing me in the right direction.



Thanks in advance



Regards

Hello there.

Im sort of a new to Mautic, and after watching several videos, i found myself in a issue involving labels.

In my page, i coded some triggers to add specific labels for mautic’s contacts. And that worked quite fine.

My issue is regarding the campaigns.

Let’s say i have a segment called Newsletter… And then, i setup a campaign for this segment… But the very first check is to check if this contact has a specific label, if does, send an email…

The problem is, mautic only check this label once, when the contact is added to the campaign, and it would be very smart of it, if it re-run this validation everytime something changes on the contact. Let’s say the my contact is not ready to receive some e-mails, but as soon as it gets ready, i’d like it to join the campaign.

Im not sure if this is how mautic works or if is there any other approuch to fix my issue, but i really appreciate any of your help pointing me in the right direction.

Thanks in advance

Regards