Mautic is not marking bounces from Amazon SES API

At first, Amazon SES are not marking contacts that are bouncing email back so I used Amazon bounce simulator and it wasn’t marking it bounce. I switched over to a different verified email and try again. It start marking bounces and even the bounce simulator email address was marked as bounce by Mautic so I thought all is good and for some reason one of my verified email wasn’t.somehow marking it bounce correctly.

Now it stopped marking it bounces and I tried the Amazon simulator email and sure enough again it not working. Here what I am seeing in the log … a bunch of same line each time when Mautic failed to mark it bounced

mautic.WARNING: Received SES webhook of type '' but couldn't understand payload []

Any idea what it mean and how to fix it? it was working fine before.

Do you have include original headers setting in Amazon SES on? Turn it off.

It’s off … Never had it turn on

ok. then I have no idea :slight_smile:

I am creating a new Topic on Amazon SES and saw this new setting …

Enable raw message delivery

Seems to be disable at default. Do we need this enabled or leave it disabled?

I fixed it by creating a new Topic …

I don’t know why this fixes it but it working now with the new SNS topic.