Mautic on Ubuntu Apache Server

Your software
My Mautic version is: 5.0.2
My PHP version is: php8
My Database type and version is: SQL-Mariadb - Ubuntu 22.04

Your problem
I have followed instructions on installing Mautic on Ubuntu Apache and I’m at the point of loading the website url /installer and I get a white screen, nothing on it, I see in the URL bar the Mautic logo but nothing loads. I’m new at this VPS server thing so I would appreciate some help and guidance please.

These errors are showing in the log:

[Tue Jan 30 00:08:22.619131 2024] [proxy_fcgi:error] [pid 19371:tid 140485763003968] [client] AH01071: Got error ‘PHP message: PHP Warning: require(/var/www/mautic/app/…/autoload.php): Failed to open stream:
No such file or directory in /var/www/mautic/app/config/bootstrap.php on line 5PHP message: PHP Fatal error: Uncaught Error: Failed opening required ‘/var/www/mautic/app/…/autoload.php’ (include_path=’.:/usr/share/php’) in /var/www/mautic/app/config/bootstrap.php:5\nStack trace:\n#0 /var/www/mautic/index.php(9): require()\n#1 {main}\n thrown in /var/www/mautic/app/config/bootstrap.php on line 5’


Steps I have tried to fix the problem: I have removed and re-installed Mautic with no luck,

Is this a clean VPS or you have Cpanel and maybe a Wordpress on it?

Based on message you posted PHP dependencies are not installed or path to web root is not correct.

1 Like

Hi it’s a clean VPS brand new account

I re-installed php depencies using this command:

sudo apt install software-properties-common ca-certificates lsb-release apt-transport-https 

Also upgraded to php8.1

Dependencies of Mautic project located in composer.json. You will also need to install some PHP extensions.

that usually get installed in: /vendor

It sounds like it might be helpful for you to delegate setup of Mautic to someone who is more comftable with technical side of things.

Drop me a DM, if you are interested.

Hi thanks for the help, I finally got it to work by using these instructions:

Now my next challenge is to find a way to send SMS text messages to admins (agents) with the full content of a web form (example for real estate agents, once they receive a lead from that form, all content needs to be sent via SMS). In the past I had someone programmed a script that added an option in the form action right below the email option he added an option send SMS and all I had to do is enter the agent mobile number and it worked like a charm, unfortunately when upgrading to newer version I lost everything. On my previous shared hosting installation last week, I had managed to create a script with ChatGPT through a webhook option in campaign automation and after testing it, I could see in the contact events that the SMS was sent but I never received it. I also had an option in automation to send an SMS to contact also showing in events that it was 100% sent but again I never received the SMS. My shared hosting company told me that I could not use SMS Api and Twilio on shared hosting, not sure why as a few years back I was on shared hosting and it worked perfectly.

That is the reason that I went with the VPS option, so now back to square one, it’s finally installed, I will setup Twilio and run some test and keep you guys posted.

Thanks for all the help