Mautic Community Forums

Your server does not meet the minimum PHP requirements error

Imposible to start with Mautic.



I use ubuntu 14.04 and vestacp updated and working well.



Mautic gave me this message prior to installation:



Your server does not meet the minimum PHP requirements. Mautic requires PHP version 5.6.19 while your server has 5.5.9-1ubuntu4.19. Please contact your host to update your PHP installation.



Yust starting and I have a problem without solution.




Imposible to start with Mautic.

I use ubuntu 14.04 and vestacp updated and working well.

Mautic gave me this message prior to installation:

Your server does not meet the minimum PHP requirements. Mautic requires PHP version 5.6.19 while your server has 5.5.9-1ubuntu4.19. Please contact your host to update your PHP installation.

Yust starting and I have a problem without solution.

I updated on my server and cleared the cache and still nothing.
Anything you recommend I do?

Thanks

from where type php -v?

We got following error while access http://email.solidnnn.com/

[17-Feb-2017 21:59:32 UTC] PHP Fatal error: Class ‘LightSamlSymfonyBridgeBundleLightSamlSymfonyBridgeBundle’ not found in /home/investsolidcow/email.solidnnn.com/app/AppKernel.php on line 179

[quote=20473:@gamzehrealty]We got following error while access http://email.solidnnn.com/

[17-Feb-2017 21:59:32 UTC] PHP Fatal error: Class ‘LightSamlSymfonyBridgeBundleLightSamlSymfonyBridgeBundle’ not found in /home/investsolidcow/email.solidnnn.com/app/AppKernel.php on line 179[/quote]
Download composer.json from Mautic’s github, replace it with the one in your Mautic root.

php -v from the command line may be telling you what version your CLI is running. It is possible for your CLI to run different version of php than your web version.

In your mautic directory, add a phpinfotest.php file and fill it with:

<?php phpinfo();?>

Navigate to that file in your browser, it will tell you what version the http server is running.

Thank you so so so much

Are you talking about https://github.com/mautic/MauticGeneratorBundle/blob/master/composer.json
Where do I replace the code? Where in the root is it?

I can email you copy of my mautic. What’s your email?

Thanks

https://github.com/mautic/mautic the composer.json file last updated Feb 1, 2017 is what you’re looking for.

The root of your mautic is the webserver where your mautic installation is held, you’ll see composer.json there. If you don’t you aren’t in the root of mautic.

Copy/paste (or download that file to your desktop, upload it to the main directory of your mautic (you will see an existing composer.json there, rename/backup/delete it)

Make sure the composer.json you upload from your desktop is not composer.json.txt once its on your server. If it is, simply rename it to composer.json

Run composer again via CLI to include these missing bundles.

composer install

from where you download Mautic?

The composer.json is not in the root.
I used software from hosting named soft something to install

softaculus apps installer

No change. Do you want me to email the files so you can look at?

No, if you used an installer you’re probably quite out of date, it’s best to update (or start fresh).

Those app installers are never good to use. I’ve never seen one that had the latest versions of software - all stuff that was grossly out of date and undoubtedly riddled with security holes.

Its always better to install yourself, the extra time it takes also allows you to become more familiar with it, so when something breaks it’ll be that much easier to track down.

Thank you so much for all your help.

I installed a new mautic. Now I get this error

We have detected 1 major problems. You must fix them before continuing:

PHP version 5.6.x requires the PHP configuration directive always_populate_raw_post_data be set to -1. This is handled automatically by the .htaccess file when using Apache and mod_php5, but must be set manually in php.ini for other server configurations. Please add ‘always_populate_raw_post_data = -1’ to your php.ini and restart your web server.

[26-Feb-2017 05:45:44 UTC] PHP Parse error: syntax error, unexpected ‘.’, expecting ‘&’ or variable (T_VARIABLE) in /home/investsolidcow/email.solidnnn.com/app/bundles/CoreBundle/ErrorHandler/ErrorHandler.php on line 582

Thank you so much for you help but I can’t find php.ini files . Do you know where is located at?

Also should i use PHP 5.7 or php 5.6 is okay

I don’t know how to do the command line.
I am connected through ftp file. What do i do to find the php.ini file to change it to -1
I did the command in my computer nothing came up.

it looks like its never ending issue even with new install.

I asked my hosting to assign it to -1 and they just send me an email.
Now I get this error
Parse error: syntax error, unexpected ‘.’, expecting ‘&’ or variable (T_VARIABLE) in /home/investsolidcow/email.solidnnn.com/app/bundles/CoreBundle/ErrorHandler/ErrorHandler.php on line 582

I have php 5.6 installed. I updated it 5.7 and get four error message now.

Mautic is unable to write your configuration file to the appropriate location. Please check your filesystem permissions to ensure the following path is writable: /home/investsolidcow/email.solidnnn.com/app/config/local.php.
The /home/investsolidcow/email.solidnnn.com/app/cache directory must be writable. Change the permissions of the /home/investsolidcow/email.solidnnn.com/app/cache directory so that the web server can write into it.
The /home/investsolidcow/email.solidnnn.com/app/logs directory must be writable. Change the permissions of the /home/investsolidcow/email.solidnnn.com/app/logs directory so that the web server can write into it.
Install and enable the fileinfo extension.

I have three options in my hosting 5.5 5.6 and 5.7

I think they did not restart the web server.

PHP version 5.6.x requires the PHP configuration directive always_populate_raw_post_data be set to -1. This is handled automatically by the .htaccess file when using Apache and mod_php5, but must be set manually in php.ini for other server configurations. Please add ‘always_populate_raw_post_data = -1’ to your php.ini and restart your web server.