MauticTwigTemplatesBundle not shown

Your software
My Mautic version is: 5.0.2
My PHP version is: 8.1.27
My Database type and version is: mariadb-server 1:10.11.6-0+deb12u1

Your problem
My problem is: Plugin is not shown in the backend unter plugins

These errors are showing in the log:

Steps I have tried to fix the problem:

I bought the new version of the plugin, uploaded it in to mautic/plugins directory. Logged into Mautic and looked for the plugins. All the other ones are there, but not this one.

I tried it with GrapesJBuilder activated and also without it. No difference.

Any hint?

Kind regards


Did u upgrade the plugin to M5 version?
It is available on the manufacturers website.

Yes, with the 35% discount…

Wow! That is really cool!

When you upload the plugin, a couple of things to check / do:

  • make sure that the plugin that you uploaded has the right folder name
  • clear the cache: rm -rf <mautic-root>/var/cache/prod/*
  • reload the plugins: php bin/console mautic:plugins:reload --env=prod

Best, M.

I did it. And since than the site is not available any more:
The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.

Then I tried a
php bin/console mautic:update:find
which tells me that there are no updates, which is correct.

Then I did a
composer update mautic/core-lib --with-dependencies
which ran through and ended with the following error:

sh: 1: npm: not found
Script npm ci --prefer-offline --no-audit handling the npm-ci event returned with error code 127
Script @npm-ci was called via post-update-cmd

Well do I really need npm? I don’t want to install a bunch of packages that are not really needed.

It get’s annoying. Such a mess because of a plugin for which I have to pay also money!

Kind regards


Your issue is not with the plugin, your issue is with mautic installation.

NPM is required for Mautic 5 since its building some JS dependencies via that - this was not the best idea in my opinion.

You are not the only one who faced the issue either:

< Composer Setup for Mautic 5 Now Needs NPM >.

The simplest solution is to install npn and then it will run the build as finish the installation sequence.

The thing is that the build process should not be done on the production server in the first place.

The proper way to do this is to separate / isolate the generation of JS assets and then after they are built, they get transferred to the server.

Many thanks for your quick answer.
I have no problems with software depending on other software. But npm scared me a little bit with the vast majority of packages it wants to install.

Yes, my first choice is also this, that I have a developing system which I’m applying updates on and if tested, transferring them via rsync to the production server.

After testing, installing, changing and upgrading I finally got it all together.
Thanks to Joey’s Install Guide: Setup From Scratch.

I also got it managed to migrate all data from 4.4.11 to 5.0.2 using this:

Now my question is: Which folders do I need to transfer to the production environment? Is it the whole mautic folder with mautic/docroot? I guess, yes. Because the local.php file is unter mautic/config.

Many thanks. I could manage to get them installed. Yes, it was an installation problem.

And what’s new is, that cloning is finally functioning. It never worked with Mautic 4.

What I found during my first quick tests is, that I have a TWIG Template with the ID 17, which can’t be shown nor edited.

Many thanks for helping.

Kind regards


1 Like