Maxmind fails to update

Your software
My Mautic version is:v3.3.2
My PHP version is: PHP Version 7.3.27
My Database type: MariaDB

Your problem
Max mind fails to upgrade. I have no clue to why it doesn’t work… We have entered the license key and it did work fine for long time but about 3-4 Mautic upgrades ago it started to fail.


Thanks in advance for any suggestion that could help us in the right direction to solve this sort of annoying issue.

Kind regards

Have you read the documentation and used the correct format?

Yes and as mentioned it has worked well for months in the past.

however I followed the guide again and did as it recommends. I created a new API key and then applied in Mautic. Unfortunately with the same failing result as the provided screenshot.

Kind regards

Please disregard my previous post. I have figured it out. In the past we had only the license key applied and that worked fine. Now it is user-id:api-key.
I applied the change it now it works.

Thank you so much for your kind help @rcheesley :smiley:

Kind regards

No problem at all - it was a change that Maxmind made and which we implemented I think back in 3.2 perhaps? Always a good idea to check the docs for things like this, just in case (and keep an eye on the release notes!)

Glad you got it sorted!

1 Like

Thank you so much @rcheesley it is very appreciated! :+1: :heart:

Kind regards