Mautic Community Forums

Maxmind not downloading anymore after 3.2.0 update ... seems it doesn't believe I put a license key in there

Just updated to 3.2.0 and Maxmind doesn’t fetch anymore through the config panel.

Everything worked before and the license key is there, while the log tells that Mautic thinks otherwise:

[2020-12-01 16:39:10] mautic.ERROR: Failed to fetch remote IP data: A string or UriInterface object must be provided, a “NULL” was provided.
[2020-12-01 16:39:10] mautic.WARNING: MaxMind license key is required.

Again, the key is there …

Anyone?

Lex

Hi Lex,

There were some changes to how Maxmind is expecting to receive the license key, it now needs to be AccountID:Licensekey.

Sorry completely forgot to merge the 3.2 documentation PR’s and this one was missing so just added it!

1 Like

I am trying this on 4.0.1 and getting download failed. I know that @Yosu_Cadilla had written up a tutorial once - anyone know if this is still valid for 4.0.1 or if it might be outdated ?

Assuming that you are using the correct format for the license key and account ID, can you share what the error is? The syntax is in the docs linked above in case it’s needed to double check :slight_smile:

Hi @rcheesley

Thank you for pointing that out to me.

When I first started working in computers many many years ago the guys I worked with were all these geniuses and every question I had was given the same answer “RTFM”

So I went and read properly and now all is working!!

2 Likes

:woman_facepalming: :rofl: glad to hear it’s all working! It does catch people out because of that change they implemented with the license key syntax!