Mautic Community Forums

Php 7.4? Seems a bit high for min version

I see that Mautic 4 requires a min version of 7.4. This really sucks. Not everyone has the resources to ensure that all code bases they manage are running on latest versions of php (yes I know php8 is after this, but you know what I mean).

Is there any way it can run on 7.3, or will we be staying on 3.3* for some time then?

I guess no one else cares?

Did you actually look at PHP: Supported Versions ?
PHP 7.4 has active support until 28 Nov 2021 so it would be even better to support 8.0 as min version.

I always try to run the newest version of anything if I can. It will mean less work in the future with upgrading. You will have to upgrade to PHP 8.0 sooner or later.

Now that Mautic does not support 8.0 yet I will have to install 7.4 and then in the future upgrade. Would rather have 8.0 from the start of Mautic 4.0.

Lower version means more bugs, more security issues, less performance, less features…

Just stay on older version of Mautic if you want to use old version of PHP…

Not so easy mate when you have dozens of code bases to manage. M4 will exclude a lot of users I think. It’s a real shame.