Pipedrive Plugin won't install

Your software
My Mautic version is: 5.0.2
My PHP version is: 8.1
My Database type and version is:

Your problem
Hi Community!
Has anybody had success with the new Pipedrive plugin for Mautic 5? I just installed Mautic 5, uploaded the MauticPipedriveBundle (named exactly like this) folder into the /plugins directory on the server and cleared the cache.
But when I click on the “Install/Upgrade Plugins” button in Mautic, nothing happens (“0 new plugins were installed”).
I scanned through the documentary, YouTube and forums, but it got me nowhere. Does anybody have a clue what I’m missing? I’m sure the error is on my side.

These errors are showing in the log:

Steps I have tried to fix the problem: renamed the folder, reinstalled Mautic 5, extracted on the server and on desktop (as if this would make much difference anyway)

Any help is MUCH appreciated!

Hi @advantising and welcome to the community!

  1. Did you clear the Mautic cache fully?
  2. Did you check if the file / folder permissions are correct, after you uploaded the plugin into the directory?
  3. cc @npracht in case you folks can help here!

Hi! @rcheesley and thanks for getting back. I checked the folder permissions and concerning the cache: I’m actually not quite sure, I do get an error message:

Note: Mautic 4 is also still installed in a different folder, if that makes a difference

So I tried to install the Plugin at another client yesterday, same Mautic version (5.0.2), but everything else is different (differnt host etc.), but exactly the same problem! Has nobody encountered this yet? I will share my installation steps for you, maybe someone can spot the mistake:

  1. Download the ZIP on Github

  2. Upload the folder in /plugins, then extract, then rename correctly:

  3. clear the Cache (I alternatively also tried to upload the folder immediately after Mautic 5 installation and before I even clicked on “Install plugins” for the first time

See screenshot in the above post

What’s going on here? Does anybody have a clue? I don’t even understand the error message in the terminal.


Try to clear the cache with the command below (from mautic root directory)

rm -rf var/cache/dev/* var/cache/prod/*

then reload the plugins

Hi @advantising,

I remember that @lenonleite and I were attempting to help you with your issue. One question: does that plugin work for version 5?

I recommend installing it on a v4 instance to test it out, or checking its information to see if there’s any mention of compatibility with the v5.

Best of luck,

Hi again!!

@mzagmajster thanks for the try, I tried the command:

Didn’t work though:

Hey @ricfreire I was assuming it should work with Mautic 5, since it is described here: Exciting News: A New Integration Plugin for Pipedrive CRM - Mautic Community


So nobody hat this problem before?

It’s too bad, I had to kill Mautic and switch to Pipedrive for 2 clients entirely, I hope I can still offer it as a tool for future CRM solutions :frowning:

Actually its not written there, that M5 version is ready. It’s written that there will be no community plugin in M5.

I think nobody upgraded to M5 without checking if plugins are ready for M5.

Please handle the M5 version with caution in production, as important features are being rolled out continuously, like feedback loops, transactional mail improvements, etc.

As you mentioned you are reselling Mautic - if stability is important for you, consider donating part of your income to this project.