Mautic Community Forums

Please wait... unable to save or apply setting changes

Your software
My Mautic version is:
My PHP version is: 7.2.23

Your problem
My problem is:
Im unable to save or apply any setting at all, which leads to no activity being recorded whatsoever. as it seems to be restricting all the domains and I cant change that.
I really dont know much about databases, but I imagine that is a problem about not being able to writte in the database?, alldough other things works just fine.

These errors are showing in the log: last one
[2019-10-29 18:12:50] mautic.ERROR: SCHEMA ERROR: An exception occurred while executing ‘SELECT f.alias, f.is_unique_identifer as is_unique, f.type, f.object FROM mwlead_fields f WHERE f.object = ‘lead’ ORDER BY f.field_order ASC’: SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘rsqyjlmy_mwmautic.mwlead_fields’ doesn’t exist

Steps I have tried to fix the problem: re- install the whole thing.
There was another question with the same problem but no answer is detailed there so I gotta ask here.

UPDATE: After hitting save, I saw that there appears an error in the console:

1 Like

and I checked and that table does exist, it seems like the problem with the log might not be so related to this issue?
oh, I installed twice and both times I get the same issue.

1 Like

What version of Mautic? Did you do an update recently?

1 Like

Have you followed these steps: https://www.mautic.org/docs/en/tips/update-failed.html?

1 Like

php app/console mautic :update:find

Great! You are running the current version of Mautic.
Yes I have done everything now through ssh.

I was talkingto bluehost and perhaps has something to do with the mod_security thing, so I have to wait for them to de-activate it and see, I just hope that that is it haha

They need to whitelist that function. A 406 response is a telltale sign of Mod Security blocking something.

3 Likes

maybe you are using wordfence wordpress pluggin? in that case disable it. I had the same issue…

yes!, I contacted bluehost team and they disabled mod_security!, now it works

1 Like

@carlmmiko, can you mark @MxyzptlkFishStix post as a Solution, please?

1 Like

Thanks to everyone for your help! now is solved, if someone else have this question, just tell them to modify their mod_security or contact their webhost to do so if they cant acces it!.
thanks again!

2 Likes

I had a similar problem with creating forms with a redirect to a url on a hostgator shared site. I got the Mod security settings turned off by hostgator and now all good. This only seems to be a recent issue.

1 Like

Yes its an issue with Mod_security , i would never recommend a shared hosting for the mautic installation… Mautic is better performing on VPS

Perhaps, but arent thy a bit too expensive for those getting started?

Not really, you can get a free tier on AWS, Digital Ocean droplets start from a few $$ per month. Depends what you consider to be expensive really.

As this is a different topic to the original post, so I’m going to close this as a solved post :slight_smile: