Mautic Community Forums

Possible Issue with Email Frequency in 4.0.1

Your software
My Mautic version is: 4.0.1
My PHP version is: 7.4
My Database type and version is: maraud

Your problem
My problem is:

I have another open issue on this where emails are being set as queued. When I go and look at the frequency settings I see that it is set to 0 days.

I tested this a few times and get different results. I then went and changed this to 100 emails per day, did a send and everything went through.

My guess that somewhere inside Mautic it is not respecting the settings

Previous post:
I am getting lots of mails queued
image

why is this happening ?

I do not have que setup. have not changed mailing frequency. Checked user card there are no limitations there

Hi, the problem seems to be, that sometimes after upgrade frequency is set from NULL / day to 0 / day. The two values are different since NULL behaves like NO value.
So you might find yourself facing queued emails which have to be sent out in to rescheduled times.
These emails can be sent with the mautic:messages:send command.

Hey @joeyk

Thanks for that bit of info. So should people write NULL in the value of frequency or simply delete it totally ? What is the correct work around here.

Regarding the Mautic:messages:send I did try this and unfortunately it still did not send off the queued emails:

Is there something else I might be missing here ?

Hi Mike,
Is the message ready to be sent - i mean the rescheduled date is in the past?

Hey @joeyk I am not following you :frowning:

Where do I send the reschedule date ?

Hello Mike,

In the timeline of the contact you should be able to see something like “Cannot send due to frequency settings” and a triangle.

If you expand that error, you’ll be able to see a reschedule button.

Joey

1 Like

Cool!! I just learnt something super important and new!! Thanks @joeyk

So it is scheduled to only go out later today. Is there a way to trigger this earlier ?

Only from DB

1 Like

Found the table: message_queue holds all related infos.

how does one fix this problem ? I have deleted the zero from the settings and still getting queued. Is it something in the local.php file ?

Can you change to 100 ?

yes I can…

must be a better way to fix this problem though

I think the fix is to handle 0 as “turned off”. That would be a bugfix in my opinion.
Right now, you can just do quick and dirty and lift to 100.

1 Like