Mautic Community Forums

Problem importing 1mil of leads

Hi, im having a problem with importing leads. I need to import aproximatelly 1 000 000 leads, the file is about 200Mb. How can i manage that? Mautic is just telling me that it is to big file.

Hi, im having a problem with importing leads. I need to import aproximatelly 1 000 000 leads, the file is about 200Mb. How can i manage that? Mautic is just telling me that it is to big file.

That is a lot of leads!

The biggest issue you’re going to have is the file size and file upload limits on your server. Hopefully you’re running some serious hardware for your servers.

You’ll need to change php’s file upload limits (php.ini) and Mautic’s upload limits (mautic > configuration > upload limits).

I would recommend that you split your file into at least 4 - 6 files. That should get each file size down to roughly 50mb - 30mb, figure out the largest file size your servers can manage and let 'er rip.

PS; the only other solution is to do something like an php script which reads the file and uses the mautic api to load each row in and create the leads. but you’ll have to be into programming to do that.

Thank you for prompt reply Chad I will try it this way.

Hi Igor

Just checking in, how did this go for you? We’d love to hear some feedback on how mautic performs with big lead databases.

At this point we only imported approximatelly 100 k leads. We checking the performance carefully before uploading whole package.

Is there any recomanded setting for points?

I am currently trying to import 15k leads and no response. Sitting on the page “Please don’t leave this page” during import…is something happening? How can I tell?

Look at the logs. If you use Mautic 1.2.1+, open the admin right menu > System Info > Logs, if older version, look at app/logs folder content and check the server logs to see the error messages. My bet is that memory limit or script execution time limit in php.ini are too low. If you cannot increase them, divide the CSV with leads to more files and upload those separately.