Mautic Community Forums

Can't import a .csv file in Manage Leads

Each time I try to upload a .csv file in Manage Leads I get "Unable to read the imported csv file. "



I can successfully upload the same file in Assets with no problem.



The file is a small test .csv file with 11 records. I tried changing the fields around but no go.



I checked permissions in FTP.



The installation on my server is through Softaculous.

Each time I try to upload a .csv file in Manage Leads I get "Unable to read the imported csv file. "

I can successfully upload the same file in Assets with no problem.

The file is a small test .csv file with 11 records. I tried changing the fields around but no go.

I checked permissions in FTP.

The installation on my server is through Softaculous.

Same issue happened with me too. try importing smaller csv list before moving to bigger one. It was imported in my case after 3 attempts. I tried 10,000 contacts but don’t know how many imports are imported yet.

My test .csv only has 10 records on it.

@painperdu Could you share the file with us? You can change the real data. I’m interested in the file extension and structure.

Hi escpecz, any .csv file I’ve tried so far causes the same response.

My test file is https://drive.google.com/drive/u/1/folders/0Bx-7Mr5IZrcINTdrRTJMbWhWUU0

My installation is at http://ebigman.com/mautic/ with tester/tester as an admin account.

My problem was resolved by updating my installation of PHP to v5.5. I still don’t know what the problem with the earlier versions of PHP was but all seems well now.

My initial problem occurred under PHP 5.3. I tried updating to PHP 5.4 but it seemed to get worse with any visit to the Mautic installation resulting in an outright 500 server error.

Finally, updating to PHP 5.5 seems to have solved whatever was wrong.

It’s great you managed to solve it. The Mautic requirements are here for more info about supported PHP versions:

https://www.mautic.org/download/requirements/

@painperdu make sure to disable the tester account or change the password so some joker doesn’t make a mess :wink: