Mautic Community Forums

Problem with mautic API, can not save API setting

Your software
My Mautic version is: 4.0.0
My PHP version is: 7.4.22
My Database type and version is: 10.3.30-MariaDB-cll-lve

Your problem
My problem is:
I uninstall my mautic and install new mautic.
But now i can not save API setting.

These errors are showing in the log:
here the log:

[](javascript:top.window.close())

text/x-generic mautic_prod-2021-09-20.php ( ASCII text )

[2021-09-20 10:41:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 10:56:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 10:56:02] mautic.ERROR: Failed to fetch remote IP data: URI must be a string or UriInterface
[2021-09-20 10:56:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 11:11:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 11:11:02] mautic.ERROR: Failed to fetch remote IP data: URI must be a string or UriInterface
[2021-09-20 11:11:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 11:26:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 11:26:02] mautic.ERROR: Failed to fetch remote IP data: URI must be a string or UriInterface
[2021-09-20 11:26:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 11:41:01] mautic.WARNING: MaxMind license key is required.
[2021-09-20 11:41:01] mautic.ERROR: Failed to fetch remote IP data: URI must be a string or UriInterface
[2021-09-20 11:41:01] mautic.WARNING: MaxMind license key is required.
[2021-09-20 11:56:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 11:56:02] mautic.ERROR: Failed to fetch remote IP data: URI must be a string or UriInterface
[2021-09-20 11:56:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 12:11:01] mautic.WARNING: MaxMind license key is required.
[2021-09-20 12:11:01] mautic.ERROR: Failed to fetch remote IP data: URI must be a string or UriInterface
[2021-09-20 12:11:01] mautic.WARNING: MaxMind license key is required.
[2021-09-20 12:26:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 12:26:02] mautic.ERROR: Failed to fetch remote IP data: URI must be a string or UriInterface
[2021-09-20 12:26:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 12:41:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 12:41:02] mautic.ERROR: Failed to fetch remote IP data: URI must be a string or UriInterface
[2021-09-20 12:41:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 12:56:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 12:56:02] mautic.ERROR: Failed to fetch remote IP data: URI must be a string or UriInterface
[2021-09-20 12:56:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 13:11:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 13:11:02] mautic.ERROR: Failed to fetch remote IP data: URI must be a string or UriInterface
[2021-09-20 13:11:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 13:26:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 13:26:02] mautic.ERROR: Failed to fetch remote IP data: URI must be a string or UriInterface
[2021-09-20 13:26:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 13:41:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 13:41:02] mautic.ERROR: Failed to fetch remote IP data: URI must be a string or UriInterface
[2021-09-20 13:41:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 13:56:02] mautic.WARNING: MaxMind license key is required.
[2021-09-20 13:56:02] mautic.ERROR: Failed to fetch remote IP data: URI must be a string or UriInterface
[2021-09-20 13:56:02] mautic.WARNING: MaxMind license key is required.

Steps I have tried to fix the problem:
i tried nothing, please help the solution,

I believe you are trying to use MaxMind service and do not have license key: https://docs.mautic.org/en/setup/maxmind-license. Select something else in the dialog shown on the link and see if logs clear.

1 Like