Mautic Community Forums

Segment by custom field

Hi,

I’ve created a Custom Field ‘Member’ , Data Type is Select.

I have created two Options, Yes and No , default value is No



Now I’ve created a segment that filters on ‘Visitid URL like …’ . Segment contains 226 contacts

Now when I add an AND filter ‘Member equals Yes’ the segment contains 13 contacts

When I change this to ‘Member equals No’ the segment contains 3 contacts.



So No -> 3 , Yes -> 13 , in total 226? How can this happen?

Hi,
I’ve created a Custom Field ‘Member’ , Data Type is Select.
I have created two Options, Yes and No , default value is No

Now I’ve created a segment that filters on ‘Visitid URL like …’ . Segment contains 226 contacts
Now when I add an AND filter ‘Member equals Yes’ the segment contains 13 contacts
When I change this to ‘Member equals No’ the segment contains 3 contacts.

So No -> 3 , Yes -> 13 , in total 226? How can this happen?

I have the same problem. It seems a bug to me. I have created a new Custom Field as member_of

There are two available values site_1 and site_2, and the user can have multiple values (both site_1 and site_2). I also set the default value for the custom field to site_1.

I went to the user and updated his profile by selecting site 1.

When I create a new segment and choose member_of including site_1 my segment becomes empty…

Ok. If I use the same value as label for the custom field available values then I can filter but if a member has both of the values (site_1 and site_2) then he is excluded by the segment (my segment is member_of INCLUDING site_1)

Have you checked if in those 226 are anonymous leads?