Mautic Community Forums

Segment filtering not working in case of select multiple

Hi,



I have face some acute problem, delineated below:


  1. I have add a custom field named (interest product) type select multiple.


  2. Create a standalone form. In the form add a field check box group which contact field tab connect with custom field (interest product) and add properties label and value same as custom field (interest product).


  3. Create a segment which filters tab add interest product include the value.


  4. Add Cron job in Cpanel.



    The problem is when form submit the record display in the contacts. But the record could not display under the specific segment.



    Note: Cron job for text box type segment filter is working fine. But in case of check box group it is not working.



    Please suggest me how to overcome this. What I am missing?



    Thanks

    Somnath

Hi,

I have face some acute problem, delineated below:

  1. I have add a custom field named (interest product) type select multiple.

  2. Create a standalone form. In the form add a field check box group which contact field tab connect with custom field (interest product) and add properties label and value same as custom field (interest product).

  3. Create a segment which filters tab add interest product include the value.

  4. Add Cron job in Cpanel.

The problem is when form submit the record display in the contacts. But the record could not display under the specific segment.

Note: Cron job for text box type segment filter is working fine. But in case of check box group it is not working.

Please suggest me how to overcome this. What I am missing?

Thanks
Somnath

Same issue here. when is create a field of type “Select multiple” and then go and edit a contact and select a value, this value does not get saved and the field is left as blank. Thus unable to pick up a contact based on a multi select value.

Mautic Version?

We are now running with v2.10.1

Note: Cron job for text box type segment filter is working fine. But in case of select multiple it is not working. Another point is when excluding, after cron trigger it assigned all the contact in that particular segment, but if including it not working.

Hi,
can you please help to recover this problem?